summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2016-08-04 09:26:10 +0200
committerChristian Krause2016-08-04 09:26:10 +0200
commit698bb2d56fa220e2be6e4a75f13e779e025425dc (patch)
treec78b9183742166cc07702de37d7e6fa44f5ecaf0
parent0675ac53228127293d05035b35b86450287aba2a (diff)
downloadaur-698bb2d56fa220e2be6e4a75f13e779e025425dc.tar.gz
sga-0.10.14-1
- updates rpath patch - explicitly sets C++ standard
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--configure-rpath.patch4
-rw-r--r--set-standard.patch13
4 files changed, 33 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43603e276612..0d65b7ca6ca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Aug 4 07:25:44 UTC 2016
pkgbase = sga
pkgdesc = de novo sequence assembler using string graphs
- pkgver = 0.10.13
+ pkgver = 0.10.14
pkgrel = 1
url = https://github.com/jts/sga
arch = x86_64
@@ -10,9 +12,11 @@ pkgbase = sga
depends = bamtools
depends = jemalloc
depends = python
- source = sga-0.10.13.tar.gz::https://github.com/jts/sga/archive/v0.10.13.tar.gz
+ source = sga-0.10.14.tar.gz::https://github.com/jts/sga/archive/v0.10.14.tar.gz
+ source = set-standard.patch
source = configure-rpath.patch
- md5sums = d4f6aefc48c940dba96cc6513649ecdd
+ md5sums = 211edb372898d6515dcde98d17078b7b
+ md5sums = SKIP
md5sums = SKIP
pkgname = sga
diff --git a/PKGBUILD b/PKGBUILD
index f879c950fecc..5d94b6ea7d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=sga
-pkgver=0.10.13
+pkgver=0.10.14
pkgrel=1
pkgdesc="de novo sequence assembler using string graphs"
arch=('x86_64' 'i686')
@@ -10,20 +10,26 @@ license=('GPL3')
depends=('bamtools' 'jemalloc' 'python')
makedepends=('sparsehash')
source=("$pkgname-$pkgver.tar.gz::https://github.com/jts/sga/archive/v$pkgver.tar.gz"
+ 'set-standard.patch'
'configure-rpath.patch')
-md5sums=('d4f6aefc48c940dba96cc6513649ecdd'
+md5sums=('211edb372898d6515dcde98d17078b7b'
+ 'SKIP'
'SKIP')
prepare() {
- cd $srcdir/$pkgname-$pkgver/src
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -p1 -i $srcdir/set-standard.patch
+ patch -p1 -i $srcdir/configure-rpath.patch
+
+ cd src
- patch -p0 -i $srcdir/configure-rpath.patch
+ ./autogen.sh
}
build() {
cd $srcdir/$pkgname-$pkgver/src
- ./autogen.sh
./configure --prefix=/usr --with-bamtools=/usr --with-jemalloc=/usr
make
diff --git a/configure-rpath.patch b/configure-rpath.patch
index 2ec981c5fb14..76c08bf9a6b2 100644
--- a/configure-rpath.patch
+++ b/configure-rpath.patch
@@ -1,5 +1,5 @@
---- configure.ac 2014-01-17 21:16:36.000000000 +0100
-+++ /tmp/configure.ac.patched 2014-11-07 14:04:25.882803929 +0100
+--- a/src/configure.ac 2014-01-17 21:16:36.000000000 +0100
++++ b/src/configure.ac 2014-11-07 14:04:25.882803929 +0100
@@ -32,8 +32,8 @@
[specify directory containing the bamtools library (http://github.com/pezmaster31/bamtools)]))
diff --git a/set-standard.patch b/set-standard.patch
new file mode 100644
index 000000000000..3e6dc2a690fa
--- /dev/null
+++ b/set-standard.patch
@@ -0,0 +1,13 @@
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -92,8 +92,8 @@ fi
+
+ # Set compiler flags.
+ AC_SUBST(AM_CXXFLAGS, "-Wall -Wextra $fail_on_warning -Wno-unknown-pragmas")
+-AC_SUBST(CXXFLAGS, "-O3")
+-AC_SUBST(CFLAGS, "-O3")
++AC_SUBST(CXXFLAGS, "-std=c++98 -O3")
++AC_SUBST(CFLAGS, "-std=gnu99 -O3")
+ AC_SUBST(CPPFLAGS, "$CPPFLAGS $openmp_cppflags $sparsehash_include $bamtools_include")
+ AC_SUBST(LDFLAGS, "$openmp_cppflags $external_malloc_ldflags $bamtools_ldflags $LDFLAGS")
+