summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Tas2022-04-29 16:31:14 +0200
committerSimon Tas2022-04-29 16:31:14 +0200
commitdc7cbd25c9392a42570e4b02222598deca9dfe5f (patch)
tree562a9e60d35284873821a181a5d6849c77e3a72d
downloadaur-dc7cbd25c9392a42570e4b02222598deca9dfe5f.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--x-sgdboop.xml4
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e51d6381d5d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sgdboop-bin
+ pkgdesc = SGDBoop is a tool that automatically applies assets from SteamGridDB directly to your Steam library
+ pkgver = 1.0.12
+ pkgrel = 1
+ url = https://www.steamgriddb.com/boop
+ arch = x86_64
+ license = MIT
+ depends = shared-mime-info
+ conflicts = sgdboop
+ source = https://github.com/SteamGridDB/SGDBoop/releases/download/v1.0.12/sgdboop-linux64.tar.gz
+ source = x-sgdboop.xml
+ sha512sums = 3c139243a43bdce7d9313654ceb942183421e8b5ad5ff9364900375dca40756de540353daae5200bb42e77093ba33554c3ef9edd10adaabbc98d8888f4219770
+ sha512sums = 35f57bab67171e96fbe2b2a11b7a4c95f06083f95af683286eb2014f61c0ad8bbc3ce913a7adc0cfa15337725bdf414e5360ca6a813e72c1b1622171b0c0a62d
+
+pkgname = sgdboop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ab5edcc96f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Simon Tas <simon.tas.st@gmail.com>
+
+pkgname=sgdboop-bin
+pkgname_=sgdboop
+pkgver=1.0.12
+pkgrel=1
+pkgdesc="SGDBoop is a tool that automatically applies assets from SteamGridDB directly to your Steam library"
+arch=('x86_64')
+url="https://www.steamgriddb.com/boop"
+license=('MIT')
+conflicts=('sgdboop')
+depends=('shared-mime-info')
+
+source=("https://github.com/SteamGridDB/SGDBoop/releases/download/v${pkgver}/sgdboop-linux64.tar.gz"
+ "x-$pkgname_.xml")
+sha512sums=('3c139243a43bdce7d9313654ceb942183421e8b5ad5ff9364900375dca40756de540353daae5200bb42e77093ba33554c3ef9edd10adaabbc98d8888f4219770'
+ '35f57bab67171e96fbe2b2a11b7a4c95f06083f95af683286eb2014f61c0ad8bbc3ce913a7adc0cfa15337725bdf414e5360ca6a813e72c1b1622171b0c0a62d')
+
+package() {
+ install -dm755 "${pkgdir}/usr/bin"
+ install -Dm755 "$srcdir/SGDBoop" "$pkgdir/usr/bin/SGDBoop"
+
+ install -Dm644 "$srcdir/com.steamgriddb.SGDBoop.desktop" -t "$pkgdir/usr/share/applications"
+
+ mkdir -p "$pkgdir/usr/share/mime/packages"
+ install -m644 "x-$pkgname_.xml" "$pkgdir/usr/share/mime/packages/x-$pkgname_.xml"
+
+ echo "Go to the following website and press the blue button (Step 2) to enable the boop function:"
+ echo "https://www.steamgriddb.com/boop"
+}
+
+
+
diff --git a/x-sgdboop.xml b/x-sgdboop.xml
new file mode 100644
index 000000000000..d9d7369dd269
--- /dev/null
+++ b/x-sgdboop.xml
@@ -0,0 +1,4 @@
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="x-scheme-handler/sgdb">
+ </mime-type>
+</mime-info>