summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManhong Dai2019-05-17 13:34:35 -0400
committerManhong Dai2019-05-17 13:34:35 -0400
commit3f8461848efffda9e0e89f6ce6c85a3d5d5a29f6 (patch)
tree71da8888786f4d272e658598b531704815f9c29e
parent3b69a096d8c71c1258099f9d96b54e4a5e70b0cd (diff)
downloadaur-3f8461848efffda9e0e89f6ce6c85a3d5d5a29f6.tar.gz
a list of 'depends' tested on docker image archlinux/base
-rw-r--r--PKGBUILD4
-rw-r--r--sge.install12
2 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e84af05b6da..e61ff1da3bdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,17 @@ url="https://arc.liv.ac.uk/downloads/SGE/releases/8.1.9/"
license=('GPL')
depends=(
'awk'
+ 'fakeroot'
+ 'file'
'gcc'
'grep'
'hwloc'
'inetutils'
'libtirpc'
'libxt'
+ 'make'
'openmotif'
+ 'patch'
'tcsh'
)
source=(
diff --git a/sge.install b/sge.install
index 32e7de7de6a4..9bbc951f2520 100644
--- a/sge.install
+++ b/sge.install
@@ -16,6 +16,18 @@ pre_install() {
post_install() {
cd /opt/sge/build/source/
env SGE_ROOT=/opt/sge scripts/distinst -all -local -noexit
+ echo "##################################################"
+ echo "##################################################"
+ echo "##################################################"
+ echo "export SGE_ROOT=/opt/sge"
+ echo "cd /opt/sge"
+ echo "#to install master"
+ echo "./install_qmaster"
+ echo "#to install execd"
+ echo "./install_execd"
+ echo "##################################################"
+ echo "##################################################"
+ echo "##################################################"
}
## arg 1: the new package version