summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2018-02-06 17:36:11 +0100
committerFelix Golatofski2018-02-06 17:36:11 +0100
commit983cb92e637546c95cc1aab1d9eb5c0ccfbb290a (patch)
tree552c712c0a15082e86d3041e83672c5c3decdb57
parent707b846a7cb77ee637119d5fdbc6a2d1716e615c (diff)
downloadaur-983cb92e637546c95cc1aab1d9eb5c0ccfbb290a.tar.gz
Changed over to nicehash's version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 703303c31b31..7bd50af4d466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = sgminer
pkgdesc = A multi-threaded multi-pool GPU miner for scrypt-based coins.
- pkgver = 5.1.1
- pkgrel = 3
- url = https://github.com/sgminer-dev/sgminer
+ pkgver = 5.6.1
+ pkgrel = 1
+ url = https://github.com/nicehash/sgminer/
arch = i686
arch = x86_64
license = GPL3
makedepends = opencl-headers
depends = curl
- depends = libcl
+ depends = ocl-icd
depends = libtool
depends = pkg-config
- optdepends = ncurses: For ncurses formatted screen output
+ depends = automake
+ depends = autoconf
+ optdepends = ncurses5-compat: For ncurses formatted screen output
optdepends = opencl-nvidia: OpenCL implementation for NVIDIA
optdepends = opencl-catalyst: OpenCL implementation for AMD
provides = sgminer
- source = https://github.com/sgminer-dev/sgminer/archive/5.1.1.tar.gz
- md5sums = 43ff41d5443ee0591d8f59e49c6621e2
+ source_i686 = https://github.com/nicehash/sgminer/releases/download/5.6.1/sgminer-5.6.1-nicehash-51-linux-amd64.zip
+ sha512sums_i686 = 0354a4cf25bf747435af12fe98b4c99cc9e7682bc5bf8b917897c2b3e3d0bb3838860a8d3667e4786ea34926ce7ed45b208978aa560e8f3ec7bd802272a77316
+ source_x86_64 = https://github.com/nicehash/sgminer/releases/download/5.6.1/sgminer-5.6.1-nicehash-51-linux-i386.zip
+ sha512sums_x86_64 = 19019fdf8da6e549c4fb81b06915ee810ea5110407209218e8a0206e76cde6240e1b4228179fa8836e711939037ab5138aeaa126a9a5c952ff7625cbc0d8828e
pkgname = sgminer
diff --git a/PKGBUILD b/PKGBUILD
index baacd5b75244..e763899b2582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: TheGoliath
#
pkgname=sgminer
-pkgver=5.1.1
-pkgrel=3
+pkgver=5.6.1
+pkgrel=1
pkgdesc="A multi-threaded multi-pool GPU miner for scrypt-based coins."
arch=('i686' 'x86_64')
-url="https://github.com/sgminer-dev/sgminer"
+url="https://github.com/nicehash/sgminer/"
license=('GPL3')
-depends=('curl' 'libcl' 'libtool' 'pkg-config')
+depends=('curl' 'ocl-icd' 'libtool' 'pkg-config' 'automake' 'autoconf')
makedepends=('opencl-headers')
-optdepends=('ncurses: For ncurses formatted screen output'
+optdepends=('ncurses5-compat: For ncurses formatted screen output'
'opencl-nvidia: OpenCL implementation for NVIDIA'
'opencl-catalyst: OpenCL implementation for AMD')
provides=('sgminer')
-source=(https://github.com/sgminer-dev/sgminer/archive/${pkgver}.tar.gz)
-md5sums=('43ff41d5443ee0591d8f59e49c6621e2')
+source_i686=(https://github.com/nicehash/sgminer/releases/download/${pkgver}/sgminer-${pkgver}-nicehash-51-linux-amd64.zip)
+source_x86_64=(https://github.com/nicehash/sgminer/releases/download/${pkgver}/sgminer-${pkgver}-nicehash-51-linux-i386.zip)
+sha512sums_i686=('0354a4cf25bf747435af12fe98b4c99cc9e7682bc5bf8b917897c2b3e3d0bb3838860a8d3667e4786ea34926ce7ed45b208978aa560e8f3ec7bd802272a77316')
+sha512sums_x86_64=('19019fdf8da6e549c4fb81b06915ee810ea5110407209218e8a0206e76cde6240e1b4228179fa8836e711939037ab5138aeaa126a9a5c952ff7625cbc0d8828e')
+
build() {
cd "$srcdir/$pkgname-$pkgver"