summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2018-02-06 17:57:18 +0100
committerFelix Golatofski2018-02-06 17:57:18 +0100
commitab127ac4067e66fc031056741182ebb0c56388a9 (patch)
treec3f4abb8bb2e88933dbadb0d2250e76ba02d49c0
parent83eebfd372dd0e07b93b865b7db645ccb3961008 (diff)
downloadaur-ab127ac4067e66fc031056741182ebb0c56388a9.tar.gz
Now relying on git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef989598ba40..200461f72cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,14 +13,13 @@ pkgbase = sgminer
depends = pkg-config
depends = automake
depends = autoconf
+ depends = jansson
optdepends = ncurses5-compat: For ncurses formatted screen output
optdepends = opencl-nvidia: OpenCL implementation for NVIDIA
optdepends = opencl-catalyst: OpenCL implementation for AMD
provides = sgminer
- source_i686 = https://github.com/nicehash/sgminer/releases/download/5.6.1/sgminer-5.6.1-nicehash-51-linux-i386.zip
- sha512sums_i686 = 0354a4cf25bf747435af12fe98b4c99cc9e7682bc5bf8b917897c2b3e3d0bb3838860a8d3667e4786ea34926ce7ed45b208978aa560e8f3ec7bd802272a77316
- source_x86_64 = https://github.com/nicehash/sgminer/releases/download/5.6.1/sgminer-5.6.1-nicehash-51-linux-amd64.zip
- sha512sums_x86_64 = 19019fdf8da6e549c4fb81b06915ee810ea5110407209218e8a0206e76cde6240e1b4228179fa8836e711939037ab5138aeaa126a9a5c952ff7625cbc0d8828e
+ source = sgminer::git+https://github.com/nicehash/sgminer.git
+ sha512sums = SKIP
pkgname = sgminer
diff --git a/PKGBUILD b/PKGBUILD
index fec174c87b24..3def1a455df6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,18 @@ pkgdesc="A multi-threaded multi-pool GPU miner for scrypt-based coins."
arch=('i686' 'x86_64')
url="https://github.com/nicehash/sgminer/"
license=('GPL3')
-depends=('curl' 'ocl-icd' 'libtool' 'pkg-config' 'automake' 'autoconf')
+depends=('curl' 'ocl-icd' 'libtool' 'pkg-config' 'automake' 'autoconf' 'jansson')
makedepends=('opencl-headers')
optdepends=('ncurses5-compat: For ncurses formatted screen output'
'opencl-nvidia: OpenCL implementation for NVIDIA'
'opencl-catalyst: OpenCL implementation for AMD')
provides=('sgminer')
-source_i686=(https://github.com/nicehash/sgminer/releases/download/${pkgver}/sgminer-${pkgver}-nicehash-51-linux-i386.zip)
-source_x86_64=(https://github.com/nicehash/sgminer/releases/download/${pkgver}/sgminer-${pkgver}-nicehash-51-linux-amd64.zip)
-sha512sums_i686=('0354a4cf25bf747435af12fe98b4c99cc9e7682bc5bf8b917897c2b3e3d0bb3838860a8d3667e4786ea34926ce7ed45b208978aa560e8f3ec7bd802272a77316')
-sha512sums_x86_64=('19019fdf8da6e549c4fb81b06915ee810ea5110407209218e8a0206e76cde6240e1b4228179fa8836e711939037ab5138aeaa126a9a5c952ff7625cbc0d8828e')
+source=("${pkgname}::git+https://github.com/nicehash/sgminer.git")
+sha512sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
./autogen.sh
./configure --prefix=/usr
make