summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-07-28 21:07:56 +0200
committerMichel Zou2016-07-28 21:07:56 +0200
commit47402f14658ada11f2436a8aae74dbf6b00d66eb (patch)
treef8a10b4fd06bff139787001e774a6433c55fd74a
downloadaur-47402f14658ada11f2436a8aae74dbf6b00d66eb.tar.gz
2.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..497b5aa878db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Jul 28 19:07:56 UTC 2016
+pkgbase = sgpp
+ pkgdesc = spatially adaptive sparse grids
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://sgpp.sparsegrids.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = scons
+ makedepends = swig
+ depends = armadillo
+ depends = eigen
+ depends = python2
+ source = http://sgpp.sparsegrids.org/downloads/sgpp_2.0.0.tar.gz
+ sha1sums = ba82e9cc9cf97ba27bdc1ab96ce35c7d24c6f23d
+
+pkgname = sgpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a13ec5b7e5d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=sgpp
+pkgver=2.0.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="spatially adaptive sparse grids"
+depends=('armadillo' 'eigen' 'python2')
+makedepends=('scons' 'swig')
+license=('MIT')
+url="http://sgpp.sparsegrids.org"
+source=("http://sgpp.sparsegrids.org/downloads/sgpp_${pkgver}.tar.gz")
+sha1sums=('ba82e9cc9cf97ba27bdc1ab96ce35c7d24c6f23d')
+
+prepare() {
+ cd "$srcdir/sgpp-${pkgver}"
+ sed -i "s|python pysgpp/doxy2swig|python2 pysgpp/doxy2swig|g" site_scons/ModuleHelper.py
+}
+
+build()
+{
+ cd "$srcdir/sgpp-${pkgver}"
+ export SCONSFLAGS="$MAKEFLAGS"
+ scons SG_JAVA=0 DOC=0 COMPILE_BOOST_TESTS=0 RUN_PYTHON_TESTS=0 USE_ARMADILLO=1 USE_EIGEN=1
+}
+
+package()
+{
+ cd "$srcdir/sgpp-${pkgver}"
+ # FIXME: scons install PREFIX="$pkgdir"/usr
+ install -d "$pkgdir"/usr/{lib,include}
+ install -m 644 lib/sgpp/lib*.so "$pkgdir"/usr/lib
+ for subdir in combigrid solver quadrature optimization pde datadriven base
+ do
+ cp -r $subdir/src/sgpp "$pkgdir"/usr/include
+ done
+ install -m644 */src/*.hpp "$pkgdir"/usr/include/sgpp
+ find "$pkgdir"/usr/include/sgpp -name "*.cpp"|xargs rm
+ find "$pkgdir"/usr/include/sgpp -name "*.lint"|xargs rm
+ find "$pkgdir"/usr/include/sgpp -name "*.os"|xargs rm
+ install -d "$pkgdir"/usr/lib/python2.7/site-packages
+ cp -R lib/pysgpp "$pkgdir"/usr/lib/python2.7/site-packages
+}