summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-08-03 23:57:05 +0200
committeraksr2016-08-03 23:57:05 +0200
commit64e2d2bff5c66f6b255bc1b9f2c3ce19c429ed1a (patch)
treed2e9a56157fee51e2f8a668d6f0ecdb3522815de
downloadaur-64e2d2bff5c66f6b255bc1b9f2c3ce19c429ed1a.tar.gz
Start.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab8d9622b852
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 3 21:57:05 UTC 2016
+pkgbase = sgsh-git
+ pkgdesc = Shell supporting scatter-gather pipelines
+ pkgver = r519.67a984f
+ pkgrel = 1
+ url = http://www.spinellis.gr/sw/sgsh/
+ arch = i686
+ arch = x86_64
+ license = apache,various
+ makedepends = git
+ optdepends = graphviz: to visualize the sgsh graphs
+ optdepends = perl-graph: to detect cycles (can lead to deadlocks)
+ conflicts = sgsh
+ source = sgsh-git::git+https://github.com/dspinellis/sgsh.git
+ md5sums = SKIP
+
+pkgname = sgsh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8461fa6c8a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=sgsh-git
+pkgver=r519.67a984f
+pkgrel=1
+epoch=
+pkgdesc="Shell supporting scatter-gather pipelines"
+arch=('i686' 'x86_64')
+url="https://github.com/dspinellis/sgsh"
+url="http://www.spinellis.gr/sw/sgsh/"
+license=('apache,various')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=('graphviz: to visualize the sgsh graphs'
+ 'perl-graph: to detect cycles (can lead to deadlocks)')
+checkdepends=()
+provides=()
+conflicts=('sgsh')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/dspinellis/sgsh.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/{bin,share/man/man1}
+ make INSTPREFIX="$pkgdir/usr" install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+