summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid P2018-05-05 20:01:31 -0300
committerDavid P2018-05-05 20:01:31 -0300
commit573c34b44b6b6f9d1584177eb2e753935d5aeb0f (patch)
treee23f2db46d9631da98a34ef45c8b2979d608d81c
downloadaur-573c34b44b6b6f9d1584177eb2e753935d5aeb0f.tar.gz
upgpkg: sh-elf-binutils 2.30-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD64
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea5a49d34e91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sh-elf-binutils
+ pkgdesc = A set of programs to assemble and manipulate binary and object files
+ pkgver = 2.30
+ pkgrel = 1
+ url = http://www.gnu.org/software/binutils/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = GPL
+ depends = zlib
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.30.tar.bz2
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.30.tar.bz2.sig
+ validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
+ validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
+ sha512sums = c3ce91aa20f058ec589bf18c722bf651331b394db6378900cc813cc0eea3a331a96584d5ae090630b627369510397dccc9edfcd43d4aeefc99579f277a05c72c
+ sha512sums = SKIP
+
+pkgname = sh-elf-binutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..988fb964f939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: David P. <megver83@parabola.nu>
+
+_target=sh-elf
+pkgname=$_target-binutils
+pkgver=2.30
+pkgrel=1
+pkgdesc='A set of programs to assemble and manipulate binary and object files'
+arch=('x86_64' 'i686' 'armv7h')
+url='http://www.gnu.org/software/binutils/'
+license=(GPL)
+depends=(zlib)
+source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
+sha512sums=('c3ce91aa20f058ec589bf18c722bf651331b394db6378900cc813cc0eea3a331a96584d5ae090630b627369510397dccc9edfcd43d4aeefc99579f277a05c72c'
+ 'SKIP')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
+ '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
+
+prepare() {
+ cd binutils-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd binutils-$pkgver
+
+ if [ "${CARCH}" != "i686" ]; then
+ # enabling gold linker at i686 makes the install fail
+ enable_gold='--enable-gold'
+ fi
+
+ ./configure --target=$_target \
+ --with-sysroot=/usr/$_target \
+ --prefix=/usr \
+ --disable-multilib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --disable-nls \
+ --enable-ld=default \
+ $enable_gold \
+ --enable-plugins \
+ --enable-deterministic-archives
+
+ make
+}
+
+check() {
+ cd binutils-$pkgver
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
+ # do not abort on errors - manually check log files
+ make -k LDFLAGS="" check || true
+}
+
+package() {
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+
+ # Remove info documents that conflict with host version
+ rm -r "$pkgdir"/usr/share/info
+}