summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-07-15 12:21:25 +0800
committerWu Zhenyu2023-07-15 12:21:25 +0800
commitc67e3f7c15627e75f653d740cba5501538d26f34 (patch)
treee0b54113f3d29a2ec75c1db36032bd41818cb084
downloadaur-c67e3f7c15627e75f653d740cba5501538d26f34.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7dc9a778098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = sh-undollar
+ pkgdesc = strip the dollar sign from the beginning of the terminal command
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/Freed-Wu/undollar
+ arch = any
+ license = GPL3
+ source = https://github.com/Freed-Wu/undollar/archive/.tar.gz
+ sha256sums = SKIP
+
+pkgname = sh-undollar
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a5cafba2b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96839e7a7fbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=undollar
+pkgname=sh-$_pkgname
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="strip the dollar sign from the beginning of the terminal command"
+arch=(any)
+url=https://github.com/Freed-Wu/undollar
+license=(GPL3)
+source=("$url/archive/$_upstreamver.tar.gz")
+sha256sums=(SKIP)
+
+build() {
+ cd "$_pkgname" || return 1
+
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ cd "$_pkgname" || return 1
+
+ DESTDIR="$pkgdir" cmake --install build
+}