summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-02-19 01:23:13 -0600
committerHurricanePootis2024-02-19 01:23:13 -0600
commit17a320fee868be9f4947e2cdca8fcfb58dbdf86d (patch)
treeacb6decf88ab90c15aa0819fac3f556a55bdb35e
parent40ff8e1aff47760ef5390d0fcea12cc8ec0c10f7 (diff)
downloadaur-17a320fee868be9f4947e2cdca8fcfb58dbdf86d.tar.gz
Update to 13.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 648497c49fd2..090b8180040f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sh3eb-elf-gcc
pkgdesc = The GNU Compiler Collection for the sh3eb-elf target.
- pkgver = 11.1.0
+ pkgver = 13.2.0
pkgrel = 1
url = http://gcc.gnu.org
arch = i686
@@ -17,10 +17,9 @@ pkgbase = sh3eb-elf-gcc
options = zipman
options = docs
options = !strip
- source = https://gcc.gnu.org/pub/gcc/releases/gcc-11.1.0/gcc-11.1.0.tar.xz
- source = https://isl.gforge.inria.fr/isl-0.24.tar.xz
- sha256sums = 4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf
- sha256sums = ff6625f44c97908182142cfb2976bcfeacb6d7e83297de7692265adc7abb13f6
+ source = https://gcc.gnu.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz
+ source = https://libisl.sourceforge.io/isl-0.24.tar.xz
+ sha256sums = e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da
+ sha256sums = 043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad
pkgname = sh3eb-elf-gcc
-
diff --git a/PKGBUILD b/PKGBUILD
index 189a1f2e12e0..4843ad9b542c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_target="sh3eb-elf"
pkgname=${_target}-gcc
-pkgver=11.1.0
+pkgver=13.2.0
pkgrel=1
_islver=0.24
pkgdesc="The GNU Compiler Collection for the ${_target} target."
@@ -14,9 +14,9 @@ url="http://gcc.gnu.org"
depends=("${_target}-binutils" 'libmpc' 'elfutils')
options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!strip')
source=("https://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz"
- "https://isl.gforge.inria.fr/isl-${_islver}.tar.xz")
-sha256sums=('4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf'
- 'ff6625f44c97908182142cfb2976bcfeacb6d7e83297de7692265adc7abb13f6')
+ "https://libisl.sourceforge.io/isl-${_islver}.tar.xz")
+sha256sums=('e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da'
+ '043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad')
prepare() {
cd "${srcdir}/gcc-${pkgver/+/-}"
@@ -43,10 +43,6 @@ build() {
--target=${_target} \
--host=$CHOST \
--build=$CHOST \
- --disable-shared \
- --disable-nls \
- --disable-tls \
- --disable-threads \
--enable-languages=c,c++ \
--enable-multilib \
--with-system-zlib \
@@ -61,7 +57,8 @@ build() {
--with-gnu-as \
--with-gnu-ld \
--disable-libssp \
- --disable-__cxa_atexit
+ --disable-__cxa_atexit \
+ --enable-lto
make all-gcc all-target-libgcc
}
@@ -73,6 +70,7 @@ package() {
rm -rf "${pkgdir}/usr/share/man/man7/"
rm -rf "${pkgdir}/usr/share/info"
+ rm -rf "${pkgdir}/usr/share/locale"
cp -r "${pkgdir}"/usr/libexec/* "${pkgdir}/usr/lib/"
rm -rf "${pkgdir}/usr/libexec"