summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2021-03-12 21:21:43 +0100
committerEric Engestrom2021-03-14 14:43:25 +0100
commitdc052fdd473fe8b306447643dbe78b48dfe49737 (patch)
treefef8c5bef9c46504ce02b5bd9fc2ffadb8fb8357
parentbd8095d2f3f4cc00565e70dde7b82729eca05463 (diff)
downloadaur-dc052fdd473fe8b306447643dbe78b48dfe49737.tar.gz
Track submodules in the package sources
build() is not supposed to fetch anything, and adding the submodules to the sources allows AUR wrappers to manage caches instead of always re-downloading everything.
-rw-r--r--PKGBUILD40
1 files changed, 39 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d2e95dcb5f9..ba52e6f2887f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,13 +17,51 @@ depends=(gtk3 sdl2 sfml assimp glew glm spirv-headers)
makedepends=(git cmake python)
source=("git+https://github.com/dfranx/SHADERed.git#tag=v$pkgver"
+ "git+https://github.com/dfranx/ImGuiColorTextEdit"
+ "git+https://github.com/dfranx/SPIRV-VM.git"
+ "git+https://github.com/dfranx/ShaderExpressionParser"
+ "git+https://github.com/dfranx/SpvGenTwo"
+ "git+https://github.com/dfranx/assimp.git"
+ "git+https://github.com/KhronosGroup/glslang"
+ "git+https://github.com/dfranx/imgui.git"
+ "git+https://github.com/jtilly/inih"
+ "git+https://github.com/zeux/pugixml"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers"
+ "git+https://github.com/KhronosGroup/SPIRV-Tools.git"
"SHADERed.sh")
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'e501a371996c373988bd74733f288c8caa6b44d88439c5d52b18e14b4766420c')
+prepare() {
+ cd SHADERed
+ git submodule init
+ git config submodule.'libs/ImGuiColorTextEdit'.url "$srcdir/ImGuiColorTextEdit"
+ git config submodule.'libs/SPIRV-VM'.url "$srcdir/SPIRV-VM"
+ git config submodule.'libs/ShaderExpressionParser'.url "$srcdir/ShaderExpressionParser"
+ git config submodule.'libs/SpvGenTwo'.url "$srcdir/SpvGenTwo"
+ git config submodule.'libs/assimp'.url "$srcdir/assimp"
+ git config submodule.'libs/glslang'.url "$srcdir/glslang"
+ git config submodule.'libs/imgui'.url "$srcdir/imgui"
+ git config submodule.'libs/inih'.url "$srcdir/inih"
+ git config submodule.'libs/pugixml'.url "$srcdir/pugixml"
+ git config submodule.'libs/spirv-headers'.url "$srcdir/SPIRV-Headers"
+ git config submodule.'libs/spirv-tools'.url "$srcdir/SPIRV-Tools"
+ git submodule update
+}
+
build() {
cd SHADERed/
- git submodule update --init --recursive
cmake .
make
}