summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2018-09-27 00:36:43 +1000
committerJonathan Liu2018-09-27 00:38:24 +1000
commited963de11ace7fb4723271a3cdb8ec2368c33351 (patch)
tree7dd5aa6a1bd0ef3a71b537503aaced4ebd521d71
parentb19fe0ea3b846279e6a3385d1258fecbffcd0e5c (diff)
downloadaur-shadergen.tar.gz
Update to 3.5.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68c0e39b7956..7c7d130d0b7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Feb 22 07:04:55 UTC 2017
pkgbase = shadergen
pkgdesc = Automatically generates OpenGL Shading Language shaders that duplicate fixed function OpenGL behavior
- pkgver = 3.3.1
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/mojocorp/ShaderGen
arch = i686
arch = x86_64
license = BSD
- depends = glew
- depends = qt4
- source = https://github.com/mojocorp/ShaderGen/archive/v3.3.1.tar.gz
- md5sums = 07528cd57b6f1e3efbc8788042361ef8
+ depends = qt5-base
+ source = https://github.com/mojocorp/ShaderGen/archive/3.5.0.tar.gz
+ md5sums = d260b8f10f46ad3da41d544388349996
pkgname = shadergen
diff --git a/PKGBUILD b/PKGBUILD
index 3a6302f94cd0..ed9d05ebcf6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Jonathan Liu <net147@gmail.com>
pkgname=shadergen
_realpkgname=ShaderGen
-pkgver=3.3.1
+pkgver=3.5.0
pkgrel=1
pkgdesc="Automatically generates OpenGL Shading Language shaders that duplicate fixed function OpenGL behavior"
arch=('i686' 'x86_64')
url="https://github.com/mojocorp/ShaderGen"
license=('BSD')
-depends=('glew' 'qt4')
-source=("https://github.com/mojocorp/${_realpkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('07528cd57b6f1e3efbc8788042361ef8')
+depends=('qt5-base')
+source=("https://github.com/mojocorp/${_realpkgname}/archive/${pkgver}.tar.gz")
+md5sums=('d260b8f10f46ad3da41d544388349996')
prepare() {
cd "${_realpkgname}-${pkgver}"
- qmake-qt4
+ qmake
}
build() {