aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragentcobra2018-09-03 06:37:22 +0200
committeragentcobra2018-09-03 06:37:22 +0200
commit16b1c03d04415bc5926fc68d3d0707e16ceeb9ab (patch)
tree6ca3cb0b0f7781392a5c1d0ecc811fb85bb7621b
parentb90b7ae2c0b80da59c071264de05cc6bdde6b600 (diff)
downloadaur-16b1c03d04415bc5926fc68d3d0707e16ceeb9ab.tar.gz
fix font issue
https://github.com/NicolasGuilloux/blade-shadow-beta/commit/ef23e5f217dcff5b8e82ef2e7f309197d7411679
-rw-r--r--.SRCINFO14
-rw-r--r--INSTALL22
-rw-r--r--Makefile23
-rw-r--r--PKGBUILD28
4 files changed, 70 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7263b119057..4cc2a268de9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = shadow-beta
pkgdesc = Shadow launcher
pkgver = 0.7.6
- pkgrel = 2
+ pkgrel = 5
url = http://shadow.tech
+ install = INSTALL
arch = x86_64
license = unknown
depends = desktop-file-utils
@@ -23,9 +24,18 @@ pkgbase = shadow-beta
depends = qt5-base
depends = qt5-svg
depends = sdl2
+ depends = libappindicator
+ depends = libcurl-compat
+ depends = sdl
+ depends = gcc7-libs
+ depends = ttf-dejavu
provides = shadow-beta
source = https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadowbeta.deb
- md5sums = 6fc188e0e818c9d3af6dbb2d51a88f91
+ source = https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl
+ source = https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = shadow-beta
diff --git a/INSTALL b/INSTALL
index 6533cf37c090..907d63ba4f27 100644
--- a/INSTALL
+++ b/INSTALL
@@ -4,6 +4,28 @@ post_install() {
do
gpasswd -a $user input
done
+
+ # Create the link to the binary
+ ln -sf '/opt/Shadow Beta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
+
+ ## Fix fonts
+
+ # Truetype directory exists (not a symlink !)
+ if [ -d /usr/share/fonts/truetype ]; then
+
+ # Create TTF folder if not exists
+ if [ ! -d /usr/share/fonts/TTF ]; then
+ mkdir /usr/share/fonts/TTF
+ fi
+
+ # Move everything in the TTF folder
+ mv /usr/share/fonts/truetype/* /usr/share/fonts/TTF/
+ rm -R /usr/share/fonts/truetype
+ fi
+
+ # Create a symlink to TTF folder
+ if [ ! -e /usr/share/fonts/truetype ]; then
+ ln -sf "/usr/share/fonts/TTF" "/usr/share/fonts/truetype"
fi
}
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ed35d69cd3db
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+
+help:
+ @grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
+
+build:clear ## Build pakage
+ makepkg -s
+
+clear: ## Clear files
+ rm -rf ./pkg
+ rm -rf ./src
+ rm -f ./shadowbeta.deb
+ rm -f ./shadow-beta-*.pkg.tar
+ rm -f ./*.pl
+ rm -f ./*~
+
+install:build ## Install package with pacman
+ sudo pacman -U shadow-beta-*.pkg.tar
+
+pkgsum: ## update pkgsum with updpkgsums
+ updpkgsums
+
+srcinfo: ## génération .SRCINFO
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index acba83de9d73..509a4aab2b34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=shadow-beta
pkgver=0.7.6
-pkgrel=3
+pkgrel=5
pkgdesc="Shadow launcher"
arch=('x86_64')
url="http://shadow.tech"
license=('unknown')
depends=('desktop-file-utils' 'freetype2' 'gcc54' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu')
provides=(shadow-beta)
-source=('https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadowbeta.deb' 'https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl')
+source=('https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadowbeta.deb' 'https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl' 'https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl')
md5sums=('6fc188e0e818c9d3af6dbb2d51a88f91'
- '4e30455d9093957892dbc68c26b1d10a')
+ '7d2a0f006a6089ea5a46512b8eadda92'
+ '1ba5f5e8f5abc8568ab16bcee852bf86')
install=INSTALL
# Get the version as a datetime
@@ -44,9 +45,14 @@ package() {
chmod +x ../wrapper.pl
mv ../wrapper.pl "${pkgdir}/opt/Shadow Beta/shadow-wrapper.pl"
+ ### Move the Report.pl
+ chmod g-w ../report.pl
+ chmod +x ../report.pl
+ mv ../report.pl "${pkgdir}/opt/Shadow Beta/report.pl"
+
### Edit launcher
sed '/^Exec/ d' < "${pkgdir}/usr/share/applications/shadow-beta.desktop" > shadow-beta.desktop
- echo "Exec=\"/opt/Shadow Beta/shadow-wrapper.pl\" %U --opt-launch" >> shadow-beta.desktop
+ echo "Exec=\"/opt/Shadow Beta/shadow-wrapper.pl\" %U" >> shadow-beta.desktop
chmod g-w shadow-beta.desktop
rm "${pkgdir}/usr/share/applications/shadow-beta.desktop"
@@ -56,23 +62,15 @@ package() {
### Fix stuff
# Create lib directory
- mkdir "${pkgdir}/usr/lib"
+ mkdir -p "${pkgdir}/usr/lib"
# Correct Libjson-c
if [ ! -f /usr/lib/libjson-c.so.3 ]; then
- ln -f -s "libjson-c.so" "${pkgdir}/usr/lib/libjson-c.so.3"
+ ln -f -s -r "libjson-c.so" "${pkgdir}/usr/lib/libjson-c.so.3"
fi
# Correct Libubsan
if [ ! -f /usr/lib/libubsan.so.0 ]; then
- ln -f -s "gcc/x86_64-pc-linux-gnu/7.3.1/libubsan.so.0" "${pkgdir}/usr/lib/libubsan.so.0"
- fi
-
- # Create font directory
- mkdir "${pkgdir}/usr/share/fonts"
-
- # Fix the font issue
- if [ ! -d /usr/share/fonts/truetype ]; then
- ln -f -s "TTF" "${pkgdir}/usr/share/fonts/truetype"
+ ln -f -s -r "gcc/x86_64-pc-linux-gnu/7.3.1/libubsan.so.0" "${pkgdir}/usr/lib/libubsan.so.0"
fi
}