aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragentcobra2018-10-27 08:26:06 +0200
committeragentcobra2018-10-27 10:57:54 +0200
commit3a5d48f1be06603c9daceb7cec088a66c48f66e7 (patch)
tree2825e73350527e76f53969bdf73c73bc67df5098
parentd78ea9e9a480138b0ff8c4a63f459a7c19b5b120 (diff)
downloadaur-3a5d48f1be06603c9daceb7cec088a66c48f66e7.tar.gz
checksum update
-rw-r--r--.SRCINFO4
-rw-r--r--INSTALL47
-rw-r--r--PKGBUILD17
-rw-r--r--shadow-beta.install54
4 files changed, 59 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfc32f2c1665..8fa6066b59f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shadow-beta
pkgdesc = Shadow launcher
pkgver = 0.8.62
- pkgrel = 1
+ pkgrel = 2
url = http://shadow.tech
install = INSTALL
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = shadow-beta
depends = libxss
provides = shadow-beta
source = https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadow-alpha-bionic.zip
- md5sums = bc290cee83021c95f2ecc2a70b12d859
+ md5sums = bb5adca354d043b10bc5aca0a5afb37a
pkgname = shadow-beta
diff --git a/INSTALL b/INSTALL
index e8576f4d9817..e69de29bb2d1 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,47 +0,0 @@
-post_install() {
- # Adding all users to the input group
- for user in `ls /home`
- do
- gpasswd -a $user input
- done
-
- # Create the link to the binary
- ln -sf '/opt/shadowbeta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
-
- ## Fix fonts
-
- # # Truetype directory exists (not a symlink !)
- # if [ -d /usr/share/fonts/truetype ]; then
- #
- # # Create TTF folder if not exists
- # if [ ! -d /usr/share/fonts/TTF ]; then
- # mkdir /usr/share/fonts/TTF
- # fi
- #
- # # Move everything in the TTF folder
- # mv /usr/share/fonts/truetype/* /usr/share/fonts/TTF/
- # rm -R /usr/share/fonts/truetype
- # fi
- #
- # # Create a symlink to TTF folder
- # if [ ! -e /usr/share/fonts/truetype ]; then
- # ln -sf "/usr/share/fonts/TTF" "/usr/share/fonts/truetype"
- # fi
-}
-
-post_remove() {
- # Remove configuration
- for user in `ls /home`
- do
- if [ -d /home/$user/.config/Shadow\ Beta ]; then
- rm -R /home/$user/.config/Shadow\ Beta
- fi
- done
-}
-pre_upgrade(){
- rm -r "/opt/Shadow Beta"
-}
-
-post_upgrade(){
- ln -sf '/opt/shadowbeta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
-}
diff --git a/PKGBUILD b/PKGBUILD
index df29b7821346..b0c3829980c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=shadow-beta
pkgver=0.8.62
-pkgrel=1
+pkgrel=2
pkgdesc="Shadow launcher"
arch=('x86_64')
url="http://shadow.tech"
@@ -15,19 +15,8 @@ license=('unknown')
depends=('desktop-file-utils' 'freetype2' 'libuv' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu' 'libxss')
provides=(shadow-beta)
source=('https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadow-alpha-bionic.zip')
-md5sums=('bc290cee83021c95f2ecc2a70b12d859')
-install=INSTALL
-
-# Get the version as a datetime
-pkgver() {
- # Get the version of the latest Linux version
-# url="https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/latest-linux.yml"
-# content=$(curl -s -L $url)
-
- # Set the pkgver
-# echo "$content" | grep "version" | sed -e 's,version: ,,g'
-echo "0.8.62"
-}
+md5sums=('bb5adca354d043b10bc5aca0a5afb37a')
+install=$pkgname.install
# Build the package
package() {
diff --git a/shadow-beta.install b/shadow-beta.install
new file mode 100644
index 000000000000..a35d08b16823
--- /dev/null
+++ b/shadow-beta.install
@@ -0,0 +1,54 @@
+post_install() {
+ # Adding all users to the input group
+ for user in `ls /home`
+ do
+ gpasswd -a $user input
+ done
+
+ # Create the link to the binary
+ ln -sf '/opt/shadowbeta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
+
+ ## Fix fonts
+
+ # # Truetype directory exists (not a symlink !)
+ # if [ -d /usr/share/fonts/truetype ]; then
+ #
+ # # Create TTF folder if not exists
+ # if [ ! -d /usr/share/fonts/TTF ]; then
+ # mkdir /usr/share/fonts/TTF
+ # fi
+ #
+ # # Move everything in the TTF folder
+ # mv /usr/share/fonts/truetype/* /usr/share/fonts/TTF/
+ # rm -R /usr/share/fonts/truetype
+ # fi
+ #
+ # # Create a symlink to TTF folder
+ # if [ ! -e /usr/share/fonts/truetype ]; then
+ # ln -sf "/usr/share/fonts/TTF" "/usr/share/fonts/truetype"
+ # fi
+}
+
+post_remove() {
+ # Remove configuration
+ for user in `ls /home`
+ do
+ if [ -d /home/$user/.config/Shadow\ Beta ]; then
+ rm -R /home/$user/.config/Shadow\ Beta
+ fi
+ done
+}
+pre_upgrade(){
+ if [ -d "/opt/Shadow Beta" ];then
+ rm -r "/opt/Shadow Beta"
+ fi
+}
+
+post_upgrade(){
+ ln -sf '/opt/shadowbeta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
+ echo "New Hotkeys (since 0.8.62-1)"
+ echo " • lShift-lCtrl-Esc Open the Windows task manager"
+ echo " • lShift-lCtrl-Q Stop the stream"
+ echo " • lShift-lCtrl-F Toggle fullscreen or windowed"
+ echo " • lShift-lCtrl-G Toggle input grab"
+}