aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragentcobra2018-09-16 10:55:05 +0200
committeragentcobra2018-09-16 10:55:45 +0200
commitb2a8ae6f1049b4e6fd2892edad5935cba6ba5000 (patch)
treebe546acf30604a1f7628fd83bf46c5305faf1d5b
parent16b1c03d04415bc5926fc68d3d0707e16ceeb9ab (diff)
downloadaur-b2a8ae6f1049b4e6fd2892edad5935cba6ba5000.tar.gz
update gcc54 to gcc5, wrapper and report added inside
-rw-r--r--Makefile8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index ed35d69cd3db..e8c281709708 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
help:
@grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
-build:clear ## Build pakage
+build:clear recup ## Build pakage
makepkg -s
clear: ## Clear files
@@ -10,7 +10,6 @@ clear: ## Clear files
rm -rf ./src
rm -f ./shadowbeta.deb
rm -f ./shadow-beta-*.pkg.tar
- rm -f ./*.pl
rm -f ./*~
install:build ## Install package with pacman
@@ -19,5 +18,10 @@ install:build ## Install package with pacman
pkgsum: ## update pkgsum with updpkgsums
updpkgsums
+recup: ## Get git files
+ wget -O INSTALL https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/Arch/AUR/INSTALL
+ wget -O wrapper.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl
+ wget -O report.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl
+
srcinfo: ## génération .SRCINFO
makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 509a4aab2b34..e60617ff95a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,15 @@
pkgname=shadow-beta
pkgver=0.7.6
-pkgrel=5
+pkgrel=6
pkgdesc="Shadow launcher"
arch=('x86_64')
url="http://shadow.tech"
license=('unknown')
-depends=('desktop-file-utils' 'freetype2' 'gcc54' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu')
+depends=('desktop-file-utils' 'freetype2' 'gcc5' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu')
provides=(shadow-beta)
-source=('https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadowbeta.deb' 'https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl' 'https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl')
-md5sums=('6fc188e0e818c9d3af6dbb2d51a88f91'
- '7d2a0f006a6089ea5a46512b8eadda92'
- '1ba5f5e8f5abc8568ab16bcee852bf86')
+source=('https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadowbeta.deb')
+md5sums=('6fc188e0e818c9d3af6dbb2d51a88f91')
install=INSTALL
# Get the version as a datetime