summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel2017-04-21 22:25:43 -0700
committerJoel2017-04-21 22:25:43 -0700
commit95842721bc5426c9ac775835863b21741867a224 (patch)
tree4b6ee8f9bec3077d7b35765cd4ea3c3f07cd7e6a
parenta885d05bf0bc7fe12f39a0f00fec2213ae70252b (diff)
downloadaur-95842721bc5426c9ac775835863b21741867a224.tar.gz
update to v3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8330a7f79fe..a28766e936e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = shadow-icon-theme
pkgdesc = This is a flat icon-theme Gnome 3.10+. The icons have colourful circular base with long shadow.
- pkgver = 2.2.2
- pkgrel = 1
- url = http://gnome-look.org/content/show.php/Shadow?content=170398
+ pkgver = 3.0
+ pkgrel = 0
+ url = https://www.gnome-look.org/content/show.php/Shadow?content=170398
arch = any
license = GPL3
- source = https://dl.opendesktop.org/api/files/download/id/1473335366/shadow-2.2.2.tar.xz
- md5sums = d0b4df239435ef4f5139de8165409fcc
+ makedepends = git
+ source = git+https://github.com/rudrab/Shadow.git
+ sha256sums = SKIP
pkgname = shadow-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index ad0772b3b11c..576470139d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
+# Maintainer: Joel <aullidolunar (at) gmai1 dot c0m >
# Maintainer: Oguzcan Kucukbayrak <oguz@okb1100.com>
pkgname=shadow-icon-theme
-pkgver=2.2.2
-pkgrel=1
-pkgdesc="This is a flat icon-theme Gnome 3.10+. The icons have colourful circular base with long shadow. "
+pkgver=3.0
+pkgrel=0
+pkgdesc="This is a flat icon-theme Gnome 3.10+. The icons have colourful circular base with long shadow."
arch=(any)
-url="http://gnome-look.org/content/show.php/Shadow?content=170398"
+url="https://www.gnome-look.org/content/show.php/Shadow?content=170398"
license=(GPL3)
-source=("https://dl.opendesktop.org/api/files/download/id/1473335366/shadow-${pkgver}.tar.xz")
-md5sums=('d0b4df239435ef4f5139de8165409fcc')
+makedepends=('git')
-package() {
- install -d "${pkgdir}"/usr/share/icons/
- tar -xf shadow-${pkgver}.tar.xz
- cp -r shadow/ "${pkgdir}"/usr/share/icons/
+source=(git+https://github.com/rudrab/Shadow.git)
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/Shadow"
+ mkdir -p "$pkgdir/usr/share/icons/shadow"
+ find . -type d -name ".git" -prune -o -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/icons/shadow/{}" \;
}