summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Guilloux2019-05-24 00:10:37 +0200
committerNicolas Guilloux2019-05-24 00:10:37 +0200
commitf80c18ac65081d908611db0b7a53016106a769cb (patch)
tree4d2160560a6f04a22bee97e3f55a77c19f627193
downloadaur-f80c18ac65081d908611db0b7a53016106a769cb.tar.gz
Create for 4.4.4
-rw-r--r--.SRCINFO39
-rw-r--r--Makefile21
-rw-r--r--PKGBUILD57
-rw-r--r--README.md9
-rw-r--r--shadow-tech.install24
5 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..168a13e78df1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = shadow-tech
+ pkgdesc = Shadow launcher (stable version)
+ pkgver = 4.4.4
+ pkgrel = 1
+ url = http://shadow.tech
+ install = shadow-tech.install
+ arch = x86_64
+ license = unknown
+ depends = desktop-file-utils
+ depends = freetype2
+ depends = libuv
+ depends = gconf
+ depends = hicolor-icon-theme
+ depends = json-c
+ depends = libappindicator-gtk2
+ depends = libbsd
+ depends = libcurl-gnutls
+ depends = libdrm
+ depends = libnotify
+ depends = libva
+ depends = libxtst
+ depends = nss
+ depends = opus
+ depends = qt5-base
+ depends = qt5-svg
+ depends = sdl2
+ depends = libappindicator
+ depends = libcurl-compat
+ depends = sdl
+ depends = gcc7-libs
+ depends = ttf-dejavu
+ depends = libxss
+ depends = libsndio-61-compat
+ provides = shadow-tech
+ source = https://update.shadow.tech/launcher/prod/linux/ubuntu_18.04/Shadow.zip
+ md5sums = d12dcdcca21bd154bf472e7b3a4b5e94
+
+pkgname = shadow-tech
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..783e75be1135
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+help:
+ @grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
+
+build:clear ## Build pakage
+ makepkg -s
+
+clear: ## Clear files
+ rm -rf ./pkg
+ rm -rf ./src
+ rm -f ./*.zip
+ rm -f ./*.pkg.tar.xz
+
+
+install:build ## Install package with pacman
+ sudo pacman -U shadow-beta-*.pkg.tar
+
+pkgsum: ## update pkgsum with updpkgsums
+ updpkgsums
+
+srcinfo: ## génération .SRCINFO
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e23c385e89c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Nover <novares.x@gmail.com>
+# Contributor: agentcobra <agentcobra@free.fr>
+
+# Creator Blade <contact@blade-group.com>
+
+# Made with https://github.com/NicolasGuilloux/blade-shadow-beta
+_commit=9add3366d25530d51d168608c54b5339b64d2a4e
+pkgname=shadow-tech
+pkgver=4.4.4
+pkgrel=1
+pkgdesc="Shadow launcher (stable version)"
+arch=('x86_64')
+url="http://shadow.tech"
+license=('unknown')
+depends=('desktop-file-utils' 'freetype2' 'libuv' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu' 'libxss' 'libsndio-61-compat')
+provides=(shadow-tech)
+source=('https://update.shadow.tech/launcher/prod/linux/ubuntu_18.04/Shadow.zip')
+md5sums=('d12dcdcca21bd154bf472e7b3a4b5e94')
+install=$pkgname.install
+
+# Build the package
+package() {
+
+ ### Create working folder
+ mkdir shadow
+
+ ### Extract zip file
+ bsdtar -x -f Shadow.zip -C shadow
+
+ ### Extract the deb
+ ar xv shadow/Shadow*.deb
+
+ ### Extract the data
+ bsdtar xf data.tar.xz
+
+ mv "${srcdir}/usr/share/icons/hicolor/0x0/" "${srcdir}/usr/share/icons/hicolor/1024x1024/"
+ mv "${srcdir}/usr/share/icons/hicolor/1024x1024/apps/shadow.png" "${srcdir}/usr/share/icons/shadow.png"
+
+ chmod -R g-w usr
+ mv usr "${pkgdir}"
+
+ chmod -R g-w opt
+ mv opt "${pkgdir}"
+
+ # Move to shortcut directory
+ cd "${pkgdir}/usr/share/applications/"
+
+ sed -i -e 's/^Categories=.*$/Categories=Games;Game;Utility;Virtualization/g' shadow.desktop
+ sed -i -e 's/^Icon=.*$/Icon=shadow.png/g' shadow.desktop
+ mv shadow.desktop "$srcdir/shadow.desktop"
+
+ # Move the source directory
+ cd "$srcdir"
+
+ chmod g-w shadow.desktop
+ mv shadow.desktop "${pkgdir}/usr/share/applications/shadow.desktop"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5b23c9f22e75
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# Custom PKBUILD
+
+This PKBUILD and INSTALL file creates a package for Arch Linux distribution compatible with the pacman package manager.
+
+This work is a support for the AUR package made by agentcobra#6142.
+
+To use it, download the files and go in this directory. Then, do a `makepkg` to build the package and finally, do `sudo pacman -U ./shadow-beta-*-x86_64.pkg.tar.xz` to install it.
+
+The only thing left for Arch users is to setup a valid VA-API installation.
diff --git a/shadow-tech.install b/shadow-tech.install
new file mode 100644
index 000000000000..180055564bb1
--- /dev/null
+++ b/shadow-tech.install
@@ -0,0 +1,24 @@
+post_install() {
+ ln -sf '/opt/Shadow/shadow' '/usr/bin/shadow'
+}
+
+post_remove() {
+ # Remove configuration
+ for user in `ls /home`
+ do
+ if [ -d /home/$user/.config/Shadow ]; then
+ rm -R /home/$user/.config/Shadow
+ fi
+ done
+}
+
+pre_upgrade(){
+ # Delete the old version of Shadow
+ if [ -d "/opt/Shadow" ]; then
+ rm -r "/opt/Shadow"
+ fi
+}
+
+post_upgrade(){
+ post_install
+}