summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2018-07-08 14:18:13 -0700
committerEric Anderson2018-07-08 14:18:13 -0700
commit921630dad84e2d1b6a2445b331462932458499ef (patch)
tree7fecc2848567fc2fb387e9e7cab1d71f944262de
parent5528a39f9d3814818896297d640d3d7a8c5881a4 (diff)
downloadaur-921630dad84e2d1b6a2445b331462932458499ef.tar.gz
Remove optdep for libtxc_dxtn; modernize PKGBUILD
libtxc_dxtn is no longer necessary, and is no longer available on the AUR, so remove the reference to reduce confusion. Remove the .install file because gtk2 now seems to use fallbacks if the engine is not available. Use bsdtar instead of unzip to avoid the makedep. Use exec in .sh since the bash process is useless while playing.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD16
-rw-r--r--shadowgrounds-survivor-launcher.sh2
-rw-r--r--shadowgrounds-survivor.install12
4 files changed, 17 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34b6e8e0e182..61038a4d9927 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
pkgbase = shadowgrounds-survivor
pkgdesc = A 3D sci-fi alien shooter - sequel to Shadowgrounds (game sold separately)
pkgver = beta11_update1
- pkgrel = 2
+ pkgrel = 3
url = http://shadowgroundsgame.com/survivor/
arch = i686
arch = x86_64
license = unknown
- makedepends = unzip
- depends = libglade
- depends = mesa
- depends = openal
- depends = libvorbis
- depends = sdl_ttf
- depends = libxmu
- depends = sdl_sound
- depends = sdl_image
- optdepends = libtxc_dxtn: texture decoding for open source ATI and Intel drivers
+ depends = lib32-libglade
+ depends = lib32-mesa
+ depends = lib32-openal
+ depends = lib32-libvorbis
+ depends = lib32-sdl_ttf
+ depends = lib32-libxmu
+ depends = lib32-sdl_sound
+ depends = lib32-sdl_image
noextract = survivorUpdate1.run
options = !strip
source = shadowgrounds-survivor-launcher.sh
source = shadowgrounds-survivor.desktop
source = hib://survivorUpdate1.run
- md5sums = 06b1b542f3b61b9967b3567d1b2f1c62
+ md5sums = baf8963e63e880dd0bf23c5751ec3c53
md5sums = 68597f3dd51bac4db6ff63b2dcec2284
md5sums = 6c38a1f3fe555b4d3f3e0a9a81a7d743
diff --git a/PKGBUILD b/PKGBUILD
index fa9cf022755e..81320410913c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=shadowgrounds-survivor
pkgver=beta11_update1
-pkgrel=2
+pkgrel=3
pkgdesc='A 3D sci-fi alien shooter - sequel to Shadowgrounds (game sold separately)'
arch=('i686' 'x86_64')
url='http://shadowgroundsgame.com/survivor/'
@@ -11,21 +11,15 @@ license=('unknown')
if [ "$CARCH" = "x86_64" ]; then
depends=('lib32-libglade' 'lib32-mesa' 'lib32-openal' 'lib32-libvorbis'
'lib32-sdl_ttf' 'lib32-libxmu' 'lib32-sdl_sound' 'lib32-sdl_image')
- optdepends=('lib32-libtxc_dxtn: texture decoding for open source ATI and Intel drivers')
else
depends=('libglade' 'mesa' 'openal' 'libvorbis' 'sdl_ttf' 'libxmu' 'sdl_sound'
'sdl_image')
- optdepends=('libtxc_dxtn: texture decoding for open source ATI and Intel drivers')
fi
options=('!strip')
-makedepends=('unzip')
-if [ "$CARCH" = "x86_64" ]; then
- install="${pkgname}.install"
-fi
_gamepkg="survivorUpdate1.run"
source=("${pkgname}-launcher.sh" "${pkgname}.desktop" "hib://${_gamepkg}")
noextract=("${_gamepkg}")
-md5sums=('06b1b542f3b61b9967b3567d1b2f1c62'
+md5sums=('baf8963e63e880dd0bf23c5751ec3c53'
'68597f3dd51bac4db6ff63b2dcec2284'
'6c38a1f3fe555b4d3f3e0a9a81a7d743')
# You can download the Humble Indie Bundle file manually, or you can configure
@@ -41,9 +35,11 @@ md5sums=('06b1b542f3b61b9967b3567d1b2f1c62'
DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download the file manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf"; echo "Read this PKGBUILD for more info."; exit 1')
PKGEXT='.pkg.tar'
-build() {
+prepare() {
cd "${srcdir}"
- unzip -o "${_gamepkg}" -d "${pkgname}-${pkgver}" || true
+
+ mkdir "${pkgname}-${pkgver}"
+ bsdtar -x -C "${pkgname}-${pkgver}" -f "${_gamepkg}"
}
package(){
diff --git a/shadowgrounds-survivor-launcher.sh b/shadowgrounds-survivor-launcher.sh
index 2ae269faed29..33539494446e 100644
--- a/shadowgrounds-survivor-launcher.sh
+++ b/shadowgrounds-survivor-launcher.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-cd /opt/shadowgrounds-survivor && ./survivor-launcher $@
+cd /opt/shadowgrounds-survivor && exec ./survivor-launcher $@
diff --git a/shadowgrounds-survivor.install b/shadowgrounds-survivor.install
deleted file mode 100644
index bfe79f39db2f..000000000000
--- a/shadowgrounds-survivor.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- cat <<EOF
-This package uses lib32-gtk2, which is easy to have misconfigured. If the GUI
-does not show up, make sure you have installed the lib32 version of your GTK+
-theme. For example: lib32-gtk-engines, lib32-gtk-engine-equinox, or
-lib32-gtk-engine-murrine
-EOF
-}
-
-post_upgrade() {
- post_install $1
-}