summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYiyao Yu2018-03-05 07:22:19 +0800
committerYiyao Yu2018-03-05 07:22:19 +0800
commit30f67e338a5547826737fdbd637b034b7e08386f (patch)
tree0ac3f8bae2161bc01c7eaae92010a28fb2cb489b
parente2815c3b77e967bed795b82dc30cfd77d4a931a3 (diff)
downloadaur-30f67e338a5547826737fdbd637b034b7e08386f.tar.gz
Tests are now disabled by default. Change _enabletests to 1 to run them.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd76462cebed..ee88f747250a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shadowsocks-git
pkgdesc = A lightweight tunnel proxy
- pkgver = 2.9.1.r21.g2ab8c6b
- pkgrel = 2
+ pkgver = 2.9.1.r24.ge332ec9
+ pkgrel = 1
url = https://github.com/shadowsocks/shadowsocks/tree/master
install = shadowsocks.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 6a3852087c36..11fb8589d3e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
# Maintainer: Yiyao Yu <yuydevel@protonmail.com>
+# Change the following to 1 if you want to run tests before packaging
+_enabletests=0
+
_pkgname=shadowsocks
pkgname="${_pkgname}-git"
-pkgver=2.9.1.r21.g2ab8c6b
-pkgrel=2
+pkgver=2.9.1.r24.ge332ec9
+pkgrel=1
pkgdesc="A lightweight tunnel proxy"
license=('Apache')
_url="https://github.com/shadowsocks/shadowsocks"
@@ -33,7 +36,12 @@ prepare(){
check() {
cd shadowsocks
- tests/jenkins.sh || warning "Tests failed"
+ if [ ${_enabletests} -eq 1 ]; then
+ echo Running tests, this might take a while...
+ tests/jenkins.sh || warning "Tests failed"
+ else
+ echo Tests have been disabled, set _enabletests to 1 if you want to run them.
+ fi
}
package() {