summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordatabase641282022-09-11 03:28:41 +0800
committerdatabase641282022-09-11 03:28:41 +0800
commit6ec68d7bde215b4a858c1948f756266eebdced26 (patch)
tree51a0b34bd0a7d98aa7ea37761de06070c61a5a75
parent92c3119096bd513de0001ebe94f1063527f97a2b (diff)
downloadaur-6ec68d7bde215b4a858c1948f756266eebdced26.tar.gz
🔼 Update to v1.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--client.json117
-rw-r--r--config.json155
-rw-r--r--server.json18
-rw-r--r--shadowsocks-go.service11
-rw-r--r--shadowsocks-go@.service11
7 files changed, 16 insertions, 346 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e74643ed359d..d8cfec32296e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shadowsocks-go-git
pkgdesc = A versatile and efficient proxy platform for secure communications
- pkgver = 1.1.0.r30.g6130263
+ pkgver = 1.2.0.r0.ga888446
pkgrel = 1
url = https://github.com/database64128/shadowsocks-go
arch = x86_64
@@ -8,22 +8,14 @@ pkgbase = shadowsocks-go-git
license = AGPL3
makedepends = git
makedepends = go
+ optdepends = shadowsocks-go-domain-sets: commonly used domain sets
+ optdepends = shadowsocks-go-geolite2-country: MaxMind GeoLite2 country database
provides = shadowsocks-go
conflicts = shadowsocks-go
backup = etc/shadowsocks-go/config.json
backup = etc/shadowsocks-go/server.json
backup = etc/shadowsocks-go/client.json
source = shadowsocks-go-git::git+https://github.com/database64128/shadowsocks-go.git
- source = shadowsocks-go.service
- source = shadowsocks-go@.service
- source = config.json
- source = server.json
- source = client.json
b2sums = SKIP
- b2sums = 78640d18aa9f343c594f5c2afee139767e1c25642de595b3a4dfae67399f973404502f31dc9f3894df82cf8ff8af7df2e01993f6c61a2434f655e59623d353a9
- b2sums = c6e2c2b21a41c87b0136c07df305d4d031a5b5040baa1a4ea760fb568c3864499a9ac43ea7e82220c895f274eb0e2913bc2fcdff270ca8aa37af4d4f43050a2f
- b2sums = 6fa6e8d11f26d7cc8515fa0ee65e63f6c4f9de6513e146de360c09a22cd7821abdfdbca82fca385b0cdc1315d73f1b12fb79b0aff634c24b65904d1bc7958552
- b2sums = 525739cbdd22feba92dc28c0db6cce48793a293e967541ab7fa31379f7f8a252041ed2bc77194e8e3fbf73489a7b5b1980db0c3db74b04685391a4b6157ef59a
- b2sums = 16e0b360754b455a97d26a9d3c5854a6a1de36618358f12309dd6a3a086f87c310514a8d8bcfd44da0f0068512a2226088f685aa4137b47e88f24a1c57cc1dfa
pkgname = shadowsocks-go-git
diff --git a/PKGBUILD b/PKGBUILD
index 369056388962..39a1380b5fcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,17 @@
_pkgname=shadowsocks-go
pkgname=$_pkgname-git
-pkgver=1.1.0.r30.g6130263
+pkgver=1.2.0.r0.ga888446
pkgrel=1
pkgdesc="A versatile and efficient proxy platform for secure communications"
arch=('x86_64' 'aarch64')
url="https://github.com/database64128/$_pkgname"
license=('AGPL3')
makedepends=('git' 'go')
+optdepends=(
+ 'shadowsocks-go-domain-sets: commonly used domain sets'
+ 'shadowsocks-go-geolite2-country: MaxMind GeoLite2 country database'
+)
provides=("$_pkgname")
conflicts=("$_pkgname")
backup=(
@@ -16,22 +20,8 @@ backup=(
"etc/$_pkgname/server.json"
"etc/$_pkgname/client.json"
)
-source=(
- "$pkgname::git+$url.git"
- "$_pkgname.service"
- "$_pkgname@.service"
- 'config.json'
- 'server.json'
- 'client.json'
-)
-b2sums=(
- 'SKIP'
- '78640d18aa9f343c594f5c2afee139767e1c25642de595b3a4dfae67399f973404502f31dc9f3894df82cf8ff8af7df2e01993f6c61a2434f655e59623d353a9'
- 'c6e2c2b21a41c87b0136c07df305d4d031a5b5040baa1a4ea760fb568c3864499a9ac43ea7e82220c895f274eb0e2913bc2fcdff270ca8aa37af4d4f43050a2f'
- '6fa6e8d11f26d7cc8515fa0ee65e63f6c4f9de6513e146de360c09a22cd7821abdfdbca82fca385b0cdc1315d73f1b12fb79b0aff634c24b65904d1bc7958552'
- '525739cbdd22feba92dc28c0db6cce48793a293e967541ab7fa31379f7f8a252041ed2bc77194e8e3fbf73489a7b5b1980db0c3db74b04685391a4b6157ef59a'
- '16e0b360754b455a97d26a9d3c5854a6a1de36618358f12309dd6a3a086f87c310514a8d8bcfd44da0f0068512a2226088f685aa4137b47e88f24a1c57cc1dfa'
-)
+source=("$pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
cd $pkgname
@@ -50,13 +40,13 @@ build() {
}
package() {
- install -Dm644 $_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname.service
- install -Dm644 $_pkgname@.service "$pkgdir"/usr/lib/systemd/system/$_pkgname@.service
- install -d "$pkgdir"/etc/$_pkgname
- install -Dm644 config.json "$pkgdir"/etc/$_pkgname/config.json
- install -Dm644 server.json "$pkgdir"/etc/$_pkgname/server.json
- install -Dm644 client.json "$pkgdir"/etc/$_pkgname/client.json
cd $pkgname
+ install -Dm644 docs/$_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname.service
+ install -Dm644 docs/$_pkgname@.service "$pkgdir"/usr/lib/systemd/system/$_pkgname@.service
+ install -d "$pkgdir"/etc/$_pkgname
+ install -Dm644 docs/config.json "$pkgdir"/etc/$_pkgname/config.json
+ install -Dm644 docs/server.json "$pkgdir"/etc/$_pkgname/server.json
+ install -Dm644 docs/client.json "$pkgdir"/etc/$_pkgname/client.json
install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
install -Dm755 $_pkgname-domain-set-converter "$pkgdir"/usr/bin/$_pkgname-domain-set-converter
}
diff --git a/client.json b/client.json
deleted file mode 100644
index 95d3135fb024..000000000000
--- a/client.json
+++ /dev/null
@@ -1,117 +0,0 @@
-{
- "servers": [
- {
- "name": "socks5",
- "listen": ":1080",
- "protocol": "socks5",
- "enableTCP": true,
- "listenerTFO": true,
- "enableUDP": true,
- "mtu": 1500
- },
- {
- "name": "http",
- "listen": ":8080",
- "protocol": "http",
- "enableTCP": true,
- "listenerTFO": true
- }
- ],
- "clients": [
- {
- "name": "ss-2022",
- "endpoint": "[2001:db8:bd63:362c:2071:a0f6:827:ab6a]:20220",
- "protocol": "2022-blake3-aes-128-gcm",
- "enableTCP": true,
- "dialerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "psk": "qQln3GlVCZi5iJUObJVNCw==",
- "iPSKs": [
- "oE/s2z9Q8EWORAB8B3UCxw=="
- ]
- },
- {
- "name": "direct",
- "protocol": "direct",
- "enableTCP": true,
- "dialerTFO": true,
- "enableUDP": true,
- "mtu": 1500
- }
- ],
- "dns": [
- {
- "name": "cf-v6",
- "addrPort": "[2606:4700:4700::1111]:53",
- "tcpClientName": "ss-2022",
- "udpClientName": "ss-2022"
- }
- ],
- "router": {
- "defaultTCPClientName": "ss-2022",
- "defaultUDPClientName": "ss-2022",
- "geoLite2CountryDbPath": "Country.mmdb",
- "domainSets": [
- {
- "name": "category-ads-all",
- "path": "ss-go-category-ads-all.txt"
- },
- {
- "name": "private",
- "path": "ss-go-private.txt"
- },
- {
- "name": "cn",
- "path": "ss-go-cn.txt"
- },
- {
- "name": "geolocation-!cn@cn",
- "path": "ss-go-geolocation-!cn@cn.txt"
- }
- ],
- "routes": [
- {
- "name": "ads",
- "clientName": "reject",
- "domainSets": [
- "category-ads-all"
- ]
- },
- {
- "name": "direct",
- "clientName": "direct",
- "domainSets": [
- "private",
- "cn",
- "geolocation-!cn@cn"
- ],
- "prefixes": [
- "0.0.0.0/8",
- "10.0.0.0/8",
- "100.64.0.0/10",
- "127.0.0.0/8",
- "169.254.0.0/16",
- "172.16.0.0/12",
- "192.0.0.0/24",
- "192.0.2.0/24",
- "192.88.99.0/24",
- "192.168.0.0/16",
- "198.18.0.0/15",
- "198.51.100.0/24",
- "203.0.113.0/24",
- "224.0.0.0/4",
- "240.0.0.0/4",
- "255.255.255.255/32",
- "::1/128",
- "fc00::/7",
- "fe80::/10"
- ],
- "geoIPCountries": [
- "CN"
- ]
- }
- ]
- },
- "udpPreferIPv6": true
-}
diff --git a/config.json b/config.json
deleted file mode 100644
index 63afbb92c5cb..000000000000
--- a/config.json
+++ /dev/null
@@ -1,155 +0,0 @@
-{
- "servers": [
- {
- "name": "socks5",
- "listen": ":1080",
- "protocol": "socks5",
- "listenerFwmark": 52140,
- "enableTCP": true,
- "listenerTFO": true,
- "enableUDP": true,
- "mtu": 1500
- },
- {
- "name": "http",
- "listen": ":8080",
- "protocol": "http",
- "listenerFwmark": 52140,
- "enableTCP": true,
- "listenerTFO": true
- },
- {
- "name": "tunnel",
- "listen": ":53",
- "protocol": "direct",
- "listenerFwmark": 52140,
- "enableTCP": true,
- "listenerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "tunnelRemoteAddress": "[2606:4700:4700::1111]:53",
- "tunnelUDPTargetOnly": false
- },
- {
- "name": "ss-2022",
- "listen": ":20220",
- "protocol": "2022-blake3-aes-128-gcm",
- "listenerFwmark": 52140,
- "enableTCP": true,
- "listenerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "psk": "qQln3GlVCZi5iJUObJVNCw==",
- "uPSKs": [
- "oE/s2z9Q8EWORAB8B3UCxw=="
- ],
- "paddingPolicy": "",
- "rejectPolicy": ""
- }
- ],
- "clients": [
- {
- "name": "ss-2022-a",
- "endpoint": "[2001:db8:bd63:362c:2071:a0f6:827:ab6a]:20220",
- "protocol": "2022-blake3-aes-128-gcm",
- "dialerFwmark": 52140,
- "enableTCP": true,
- "dialerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "psk": "qQln3GlVCZi5iJUObJVNCw==",
- "iPSKs": [
- "oE/s2z9Q8EWORAB8B3UCxw=="
- ],
- "paddingPolicy": ""
- },
- {
- "name": "ss-2022-b",
- "endpoint": "[2001:db8:a2bf:f3ef:903a:4fd1:f986:5934]:20220",
- "protocol": "2022-blake3-aes-128-gcm",
- "dialerFwmark": 52140,
- "enableTCP": true,
- "dialerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "psk": "QzhDwx0lKZ+0Sustgwtjtw==",
- "iPSKs": [
- "McxLxNcqHUb01ZedJfp55g=="
- ],
- "paddingPolicy": ""
- },
- {
- "name": "direct",
- "protocol": "direct",
- "dialerFwmark": 52140,
- "enableTCP": true,
- "dialerTFO": true,
- "enableUDP": true,
- "mtu": 1500
- }
- ],
- "dns": [
- {
- "name": "cf-v6",
- "addrPort": "[2606:4700:4700::1111]:53",
- "tcpClientName": "ss-2022-a",
- "udpClientName": "ss-2022-a"
- }
- ],
- "router": {
- "disableNameResolutionForIPRules": false,
- "defaultTCPClientName": "ss-2022-a",
- "defaultUDPClientName": "ss-2022-a",
- "geoLite2CountryDbPath": "Country.mmdb",
- "domainSets": [
- {
- "name": "example",
- "path": "ss-go-example.txt"
- }
- ],
- "routes": [
- {
- "name": "example",
- "network": "udp",
- "clientName": "ss-2022-b",
- "resolverName": "cf-v6",
- "serverNames": [
- "socks5",
- "tunnel"
- ],
- "domains": [
- "example.com"
- ],
- "domainSets": [
- "example"
- ],
- "prefixes": [
- "::/0"
- ],
- "sourcePrefixes": [
- "127.0.0.1/32",
- "::1/128"
- ],
- "ports": [
- "443"
- ],
- "sourcePorts": [
- 12345,
- 54321
- ],
- "geoIPCountries": [
- "US"
- ],
- "invertDomains": false,
- "invertPrefixes": false,
- "invertPorts": false,
- "invertSourcePrefixes": false,
- "invertSourcePorts": false,
- "invertGeoIPCountries": false
- }
- ]
- },
- "udpBatchMode": "",
- "udpBatchSize": 64,
- "udpPreferIPv6": true
-}
diff --git a/server.json b/server.json
deleted file mode 100644
index 195edc81ef14..000000000000
--- a/server.json
+++ /dev/null
@@ -1,18 +0,0 @@
-{
- "servers": [
- {
- "name": "ss-2022",
- "listen": ":20220",
- "protocol": "2022-blake3-aes-128-gcm",
- "enableTCP": true,
- "listenerTFO": true,
- "enableUDP": true,
- "mtu": 1500,
- "psk": "qQln3GlVCZi5iJUObJVNCw==",
- "uPSKs": [
- "oE/s2z9Q8EWORAB8B3UCxw=="
- ]
- }
- ],
- "udpPreferIPv6": true
-}
diff --git a/shadowsocks-go.service b/shadowsocks-go.service
deleted file mode 100644
index 50a567200543..000000000000
--- a/shadowsocks-go.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Shadowsocks Go Proxy Platform
-After=network-online.target
-Wants=network-online.target
-
-[Service]
-LimitNOFILE=524288
-ExecStart=/usr/bin/shadowsocks-go -confPath /etc/shadowsocks-go/config.json -suppressTimestamps
-
-[Install]
-WantedBy=multi-user.target
diff --git a/shadowsocks-go@.service b/shadowsocks-go@.service
deleted file mode 100644
index 706f204f6452..000000000000
--- a/shadowsocks-go@.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Shadowsocks Go Proxy Platform
-After=network-online.target
-Wants=network-online.target
-
-[Service]
-LimitNOFILE=524288
-ExecStart=/usr/bin/shadowsocks-go -confPath /etc/shadowsocks-go/%i.json -suppressTimestamps
-
-[Install]
-WantedBy=multi-user.target