summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordatabase641282022-09-08 22:56:37 +0800
committerdatabase641282022-09-08 22:56:37 +0800
commit90b1291cfc74545cbc05da65d5feaee40cbba0a5 (patch)
tree0cc0272159557bf4e8ab93f06aaa577ae68792f1
parent035f88824885ca01f919b811af961dbf008c42c8 (diff)
downloadaur-90b1291cfc74545cbc05da65d5feaee40cbba0a5.tar.gz
🐏 Add domain set converter
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c3aed13757f..e74643ed359d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shadowsocks-go-git
pkgdesc = A versatile and efficient proxy platform for secure communications
- pkgver = 1.1.0.r0.g7ceae19
+ pkgver = 1.1.0.r30.g6130263
pkgrel = 1
url = https://github.com/database64128/shadowsocks-go
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5680829dc825..a4d3fbf72a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=shadowsocks-go
pkgname=$_pkgname-git
-pkgver=1.1.0.r0.g7ceae19
+pkgver=1.1.0.r30.g6130263
pkgrel=1
pkgdesc="A versatile and efficient proxy platform for secure communications"
arch=('x86_64' 'aarch64')
@@ -46,6 +46,7 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build -ldflags='-s -w -linkmode=external' ./cmd/$_pkgname
+ go build -ldflags='-s -w -linkmode=external' ./cmd/$_pkgname-domain-set-converter
}
package() {
@@ -57,4 +58,5 @@ package() {
install -Dm644 client.json "$pkgdir"/etc/$_pkgname/client.json
cd $pkgname
install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname-domain-set-converter
}