summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspyophobia2023-06-01 11:13:29 +0800
committerspyophobia2023-06-01 11:13:29 +0800
commit584df92c89489a4921ec1013a9c7166794bf5bda (patch)
treebade373d045329a264af96310a2080230223ce59
parent035e05943786c96bac7c000d347964c1d45a98ba (diff)
downloadaur-584df92c89489a4921ec1013a9c7166794bf5bda.tar.gz
Use hard float binaries for `armv7h` architecture
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec3ad8c8fcb3..2f589d10f1e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shadowsocks-rust-bin
pkgdesc = A Rust port of shadowsocks https://shadowsocks.org/ (binary version)
pkgver = 1.15.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/shadowsocks/shadowsocks-rust
arch = x86_64
arch = armv7h
@@ -25,8 +25,8 @@ pkgbase = shadowsocks-rust-bin
sha512sums = 4ac52e6fe04e02543f54d57fccfd863f18b157fd28fb61c9a56ba46269b9dff410a80960943d911afa55b45c3fc42e98d91f8bb75e9103abf3f3dbfffb73a6e0
source_x86_64 = https://github.com/shadowsocks/shadowsocks-rust/releases/download/v1.15.3/shadowsocks-v1.15.3.x86_64-unknown-linux-gnu.tar.xz
sha512sums_x86_64 = e0a44815ed884f09df337fce30ba2ff85dcede138dfce7e49623fe8766452f7cdb24f4be528fd0eba9d0a761d6cc8843bdf8531854a8273d078b8900f7008712
- source_armv7h = https://github.com/shadowsocks/shadowsocks-rust/releases/download/v1.15.3/shadowsocks-v1.15.3.arm-unknown-linux-gnueabi.tar.xz
- sha512sums_armv7h = ad8f6f56378e24789dcba10b02d28d5d0955ca6dc615e1f65b59caabc59c9098a34315c2296e61a2c2f63c679d80b6f44e704f8b5f96152a83c200b1009328b7
+ source_armv7h = https://github.com/shadowsocks/shadowsocks-rust/releases/download/v1.15.3/shadowsocks-v1.15.3.arm-unknown-linux-gnueabihf.tar.xz
+ sha512sums_armv7h = 53062cdb3699b501bb2f529b454603022b9b0411c35c03b5db0c445748e543bb65e40d6ab6e811fbd8e1de72767952f4712d774c22945d70af8e74f1a633949f
source_aarch64 = https://github.com/shadowsocks/shadowsocks-rust/releases/download/v1.15.3/shadowsocks-v1.15.3.aarch64-unknown-linux-gnu.tar.xz
sha512sums_aarch64 = 67e68e97867e66620d197d75e4224680e9f393092041e56789264ec471394ab029f008e2337e7e68e884a08036265d02fbf130387a961b9b1663af3a5e5ade0d
diff --git a/PKGBUILD b/PKGBUILD
index 071deb06e50c..d4f94637ee0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Maintainer 2022-: spyophobia <76800505+spyophobia@users.noreply.github.com>
# Co-Maintainer: DuckSoft <realducksoft@gmail.com>
-pkgname=shadowsocks-rust-bin
+pkgname=shadowsocks-rust-bin
_pkgname=shadowsocks-rust
pkgver=1.15.3
-pkgrel=3
+pkgrel=4
pkgdesc='A Rust port of shadowsocks https://shadowsocks.org/ (binary version)'
arch=('x86_64' 'armv7h' 'aarch64')
url='https://github.com/shadowsocks/shadowsocks-rust'
@@ -21,7 +21,7 @@ source=(
"${url}/raw/v${pkgver}/examples/config_ext.json"
)
source_x86_64=("${url}/releases/download/v${pkgver}/shadowsocks-v${pkgver}.x86_64-unknown-linux-gnu.tar.xz")
-source_armv7h=("${url}/releases/download/v${pkgver}/shadowsocks-v${pkgver}.arm-unknown-linux-gnueabi.tar.xz")
+source_armv7h=("${url}/releases/download/v${pkgver}/shadowsocks-v${pkgver}.arm-unknown-linux-gnueabihf.tar.xz")
source_aarch64=("${url}/releases/download/v${pkgver}/shadowsocks-v${pkgver}.aarch64-unknown-linux-gnu.tar.xz")
sha512sums=('6d7014061bf4014faec823aa1da91f990d034c21005cbee30de7ee62744201fba7d09d58a9e536d8e63bfa6fe951107ee68482b583d887b6e358f3c3eec89b85'
@@ -30,7 +30,7 @@ sha512sums=('6d7014061bf4014faec823aa1da91f990d034c21005cbee30de7ee62744201fba7d
'9a0b81d82bf897c5461d75d941cd604cbd7f32d00c2bf775f17b37b77fcf5734903d2ec666ba9a6a340e77f31018b5dbbb8ea597797c6a00c6b1f3e2f47127e6'
'4ac52e6fe04e02543f54d57fccfd863f18b157fd28fb61c9a56ba46269b9dff410a80960943d911afa55b45c3fc42e98d91f8bb75e9103abf3f3dbfffb73a6e0')
sha512sums_x86_64=('e0a44815ed884f09df337fce30ba2ff85dcede138dfce7e49623fe8766452f7cdb24f4be528fd0eba9d0a761d6cc8843bdf8531854a8273d078b8900f7008712')
-sha512sums_armv7h=('ad8f6f56378e24789dcba10b02d28d5d0955ca6dc615e1f65b59caabc59c9098a34315c2296e61a2c2f63c679d80b6f44e704f8b5f96152a83c200b1009328b7')
+sha512sums_armv7h=('53062cdb3699b501bb2f529b454603022b9b0411c35c03b5db0c445748e543bb65e40d6ab6e811fbd8e1de72767952f4712d774c22945d70af8e74f1a633949f')
sha512sums_aarch64=('67e68e97867e66620d197d75e4224680e9f393092041e56789264ec471394ab029f008e2337e7e68e884a08036265d02fbf130387a961b9b1663af3a5e5ade0d')
package() {