summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreatradish2017-07-20 11:38:14 +0800
committereatradish2017-07-20 11:38:14 +0800
commit541fa170f6f35deab8903c03a88c8561289944f2 (patch)
treed5e46d29b0e9151d22521773bdd4d0c8c720b368
parent9fdc40894cc06a49ba31bfa10b32141fb9a9b22b (diff)
downloadaur-541fa170f6f35deab8903c03a88c8561289944f2.tar.gz
Example
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--shadowsocks-libev-redir@.service13
-rw-r--r--shadowsocks-libev-server@.service13
-rw-r--r--shadowsocks-libev-tunnel@.service13
-rw-r--r--shadowsocks-libev@.service13
6 files changed, 63 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ef22dcf25fc..9a278a52f360 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jul 20 03:15:16 UTC 2017
+# Thu Jul 20 03:38:09 UTC 2017
pkgbase = shadowsocksr-libev
pkgdesc = A Shadowsocks branches
pkgver = 4.3.1.2017.6.1
@@ -30,6 +30,10 @@ pkgbase = shadowsocksr-libev
options = docs
options = !strip
source = git+https://github.com/shadowsocksr/shadowsocksr-libev.git
+ source = shadowsocks-libev-redir@.service
+ source = shadowsocks-libev-server@.service
+ source = shadowsocks-libev-tunnel@.service
+ source = shadowsocks-libev@.service
sha1sums = SKIP
pkgname = shadowsocksr-libev
diff --git a/PKGBUILD b/PKGBUILD
index cb9803fbe002..d8895b95bdef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,12 @@ depends=('libcap' 'mbedtls' 'libev' 'libsodium'
'udns' 'pcre' 'libcorkipset' 'libbloom')
makedepends=('git' 'gcc' 'autoconf' 'libtool' 'automake' 'make' 'zlib' 'openssl' 'asciidoc' 'xmlto')
options=('docs' '!strip')
-source=('git+https://github.com/shadowsocksr/shadowsocksr-libev.git')
+source=('git+https://github.com/shadowsocksr/shadowsocksr-libev.git'
+ shadowsocks-libev-redir@.service
+ shadowsocks-libev-server@.service
+ shadowsocks-libev-tunnel@.service
+ shadowsocks-libev@.service
+ )
sha1sums=('SKIP')
_gitname='shadowsocksr-libev'
diff --git a/shadowsocks-libev-redir@.service b/shadowsocks-libev-redir@.service
new file mode 100644
index 000000000000..4364cdbc24a9
--- /dev/null
+++ b/shadowsocks-libev-redir@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Shadowsocks-Libev Client Service Redir Mode
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+CapabilityBoundingSet=CAP_NET_ADMIN CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/ss-redir -c /etc/shadowsocks/%i.json
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/shadowsocks-libev-server@.service b/shadowsocks-libev-server@.service
new file mode 100644
index 000000000000..d6e0eae3aca7
--- /dev/null
+++ b/shadowsocks-libev-server@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Shadowsocks-Libev Server Service
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/ss-server -c /etc/shadowsocks/%i.json
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/shadowsocks-libev-tunnel@.service b/shadowsocks-libev-tunnel@.service
new file mode 100644
index 000000000000..9fd469a6f23e
--- /dev/null
+++ b/shadowsocks-libev-tunnel@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Shadowsocks-Libev Client Service Tunnel Mode
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/ss-tunnel -c /etc/shadowsocks/%i.json
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/shadowsocks-libev@.service b/shadowsocks-libev@.service
new file mode 100644
index 000000000000..eb44c405ed5d
--- /dev/null
+++ b/shadowsocks-libev@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Shadowsocks-Libev Client Service
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/ss-local -c /etc/shadowsocks/%i.json
+
+[Install]
+WantedBy=multi-user.target
+