summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2015-08-24 11:17:37 +0800
committerRains2015-08-24 11:17:37 +0800
commitd74a6186de9de37d034e8773815a2d9d159690ec (patch)
tree1f16c75ac2431028d45c06567d9bb40ae1acda36
parentfa3fe1147a4ee323052dc20957d9cc95cc1f0ad7 (diff)
downloadaur-d74a6186de9de37d034e8773815a2d9d159690ec.tar.gz
fix path error
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03ca49ba9d86..4300d0abbf06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = shadowvpn-git
arch = x86_64
license = MIT
makedepends = git
- depends = sh
depends = libsodium
provides = shadowvpn
conflicts = shadowvpn
diff --git a/PKGBUILD b/PKGBUILD
index edc91dc74dcd..ada6d3558f73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A fast, safe VPN based on libsodium"
arch=('i686' 'x86_64')
url="https://github.com/clowwindy/${_pkgname}"
license=('MIT')
-depends=('sh' 'libsodium')
+depends=('libsodium')
provides=("shadowvpn")
conflicts=("shadowvpn")
makedepends=('git')
@@ -30,7 +30,7 @@ pkgver() {
prepare() {
cd ${_pkgname}
- rm -rf libsodium
+ rmdir libsodium
sed -e 's|SUBDIRS = ../libsodium||' \
-e 's|AM_CFLAGS = .*libsodium.*$|AM_CFLAGS = -lsodium|' \
@@ -43,7 +43,6 @@ prepare() {
build() {
cd ${_pkgname}
- git submodule update --init libsodium
./autogen.sh
./configure --sysconfdir=/etc --disable-static --prefix=/usr
make
@@ -52,6 +51,6 @@ build() {
package() {
cd ${_pkgname}
make DESTDIR="$pkgdir" install
- install -Dm644 samples/shadowvpn@.service "$pkgdir"/lib/systemd/system/shadowvpn@.service
+ install -Dm644 samples/shadowvpn@.service "$pkgdir"/usr/lib/systemd/system/shadowvpn@.service
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/COPYING
}