summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2015-08-19 11:37:44 +0800
committerRains2015-08-19 11:37:44 +0800
commitf8cbbc3460fe276f0f74ceffdb6c14e63ae7ee66 (patch)
treefbb73f8a46773250f038c2c92895504cb3dac6e1
downloadaur-f8cbbc3460fe276f0f74ceffdb6c14e63ae7ee66.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3f605f9cad2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = shadowvpn-git
+ pkgdesc = A fast, safe VPN based on libsodium
+ pkgver = 0.2.0.6.g17f86cc
+ pkgrel = 1
+ url = https://github.com/clowwindy/ShadowVPN
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = sh
+ depends = libsodium
+ options = !emptydirs
+ backup = etc/shadowvpn/client.conf
+ backup = etc/shadowvpn/client_down.sh
+ backup = etc/shadowvpn/client_up.sh
+ backup = etc/shadowvpn/server.conf
+ backup = etc/shadowvpn/server_down.sh
+ backup = etc/shadowvpn/server_up.sh
+ source = git+https://github.com/clowwindy/ShadowVPN.git
+ md5sums = SKIP
+
+pkgname = shadowvpn-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f72e81ab811
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78101121d56e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=shadowvpn-git
+_pkgname=ShadowVPN
+pkgver=0.2.0.6.g17f86cc
+pkgrel=1
+pkgdesc="A fast, safe VPN based on libsodium"
+arch=('i686' 'x86_64')
+url="https://github.com/clowwindy/${_pkgname}"
+license=('MIT')
+depends=('sh' 'libsodium')
+makedepends=('git')
+options=('!emptydirs')
+backup=('etc/shadowvpn/client.conf'
+ 'etc/shadowvpn/client_down.sh'
+ 'etc/shadowvpn/client_up.sh'
+ 'etc/shadowvpn/server.conf'
+ 'etc/shadowvpn/server_down.sh'
+ 'etc/shadowvpn/server_up.sh')
+source=("git+https://github.com/clowwindy/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ rmdir libsodium
+
+ sed -e 's|SUBDIRS = ../libsodium||' \
+ -e 's|AM_CFLAGS = .*libsodium.*$|AM_CFLAGS = -lsodium|' \
+ -e 's|libshadowvpn_la_LIBADD = ../libsodium/src/libsodium/libsodium.la||' \
+ -i src/Makefile.am
+
+ sed -e 's|AC_CONFIG_SUBDIRS([libsodium])||' \
+ -i configure.ac
+}
+
+build() {
+ cd ${_pkgname}
+ ./autogen.sh
+ ./configure --sysconfdir=/etc --disable-static --prefix=/usr
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/COPYING
+}