summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2015-08-24 11:06:09 +0800
committerRains2015-08-24 11:06:09 +0800
commitfa3fe1147a4ee323052dc20957d9cc95cc1f0ad7 (patch)
tree4d09addc93d235a7ec4aa33e00e4e2e11a3f3572
parenta8b5053794c02f149754e01f4bd77a9b58a8d6ca (diff)
downloadaur-fa3fe1147a4ee323052dc20957d9cc95cc1f0ad7.tar.gz
add shadowvpn@.service
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e89adccdadd1..03ca49ba9d86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shadowvpn-git
pkgdesc = A fast, safe VPN based on libsodium
- pkgver = 0.2.0.6.g17f86cc
+ pkgver = 0.2.0.7.g84135b1
pkgrel = 1
url = https://github.com/clowwindy/ShadowVPN
arch = i686
@@ -18,6 +18,7 @@ pkgbase = shadowvpn-git
backup = etc/shadowvpn/server.conf
backup = etc/shadowvpn/server_down.sh
backup = etc/shadowvpn/server_up.sh
+ backup = lib/systemd/system/shadowvpn@.service
source = git+https://github.com/rains31/ShadowVPN.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 186249a21e78..edc91dc74dcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=shadowvpn-git
_pkgname=ShadowVPN
-pkgver=0.2.0.6.g17f86cc
+pkgver=0.2.0.7.g84135b1
pkgrel=1
pkgdesc="A fast, safe VPN based on libsodium"
arch=('i686' 'x86_64')
@@ -18,7 +18,8 @@ backup=('etc/shadowvpn/client.conf'
'etc/shadowvpn/client_up.sh'
'etc/shadowvpn/server.conf'
'etc/shadowvpn/server_down.sh'
- 'etc/shadowvpn/server_up.sh')
+ 'etc/shadowvpn/server_up.sh'
+ 'lib/systemd/system/shadowvpn@.service')
source=("git+https://github.com/rains31/${_pkgname}.git")
md5sums=('SKIP')
@@ -29,7 +30,7 @@ pkgver() {
prepare() {
cd ${_pkgname}
- rmdir libsodium
+ rm -rf libsodium
sed -e 's|SUBDIRS = ../libsodium||' \
-e 's|AM_CFLAGS = .*libsodium.*$|AM_CFLAGS = -lsodium|' \
@@ -42,6 +43,7 @@ prepare() {
build() {
cd ${_pkgname}
+ git submodule update --init libsodium
./autogen.sh
./configure --sysconfdir=/etc --disable-static --prefix=/usr
make
@@ -50,5 +52,6 @@ build() {
package() {
cd ${_pkgname}
make DESTDIR="$pkgdir" install
+ install -Dm644 samples/shadowvpn@.service "$pkgdir"/lib/systemd/system/shadowvpn@.service
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/COPYING
}