summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza Ayinmehr2019-04-01 00:39:12 +0430
committerAlireza Ayinmehr2019-04-01 00:39:12 +0430
commit076212f0e2a1fcbbe35056215b4c1d83d25e19c7 (patch)
treec36f019f547bd44b01f3cabd76e27e256828e738
downloadaur-076212f0e2a1fcbbe35056215b4c1d83d25e19c7.tar.gz
Initialize version 0.0.2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e97b6c83ad14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shahab-fonts
+ pkgdesc = Shahab is a Persian/Arabic font.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/font-store/ShahabFont
+ arch = any
+ license = OFL-1.1
+ depends = fontconfig
+ provides = ttf-shahab
+ conflicts = ttf-shahab
+ source = shahab-fonts-0.0.2.zip::https://github.com/font-store/ShahabFont/releases/download/v0.0.2/pack.0.0.2.zip
+ sha512sums = 87ee2a2e84ac20cf69227bd997c9287ccf25faec3243cb0dcd536c3903c140f73cdd3c3b22db1b759e9f27b74b80391fe5591799725946bece19170550259bc4
+
+pkgname = shahab-fonts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..35f33d0fc7f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.zip
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7cbd9a218aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Alireza Ayinmehr <alireza.darksun@gmail.com>
+
+pkgname='shahab-fonts'
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='Shahab is a Persian/Arabic font.'
+url='https://github.com/font-store/ShahabFont'
+arch=(any)
+license=('OFL-1.1')
+depends=('fontconfig')
+provides=('ttf-shahab')
+conflicts=('ttf-shahab')
+source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/pack.${pkgver}.zip")
+sha512sums=('87ee2a2e84ac20cf69227bd997c9287ccf25faec3243cb0dcd536c3903c140f73cdd3c3b22db1b759e9f27b74b80391fe5591799725946bece19170550259bc4')
+
+package() {
+ install -Dt "${pkgdir}/usr/share/fonts/${pkgname%-fonts}" -m644 ./fonts/*.ttf
+}