summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Heimbach2020-04-24 19:23:15 +0200
committerIngo Heimbach2020-04-24 19:23:32 +0200
commit5378b0af83830d0573a2cfe780f3a82c466a1ee0 (patch)
tree40e223623e142a570f785ccbe7e638cc587bc9be
downloadaur-5378b0af83830d0573a2cfe780f3a82c466a1ee0.tar.gz
Add a `PKGBUILD` for `shallow-appify` version v0.4.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..442ec3967225
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = shallow-appify
+ pkgdesc = Converts any executable to a non-self-contained mac app bundle which depends on system libraries.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/IngoHeimbach/shallow-appify
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-jinja
+ depends = python-pillow
+ source = https://github.com/IngoHeimbach/shallow-appify/archive/v0.4.1.tar.gz
+ sha256sums = 1f0dc5fa855c7b171d1c94a4d39558a3371489ac8be79dc1cab8ae29f2576be3
+
+pkgname = shallow-appify
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2003141c0783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..294e77be0fed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ingo Heimbach <i.heimbach@fz-juelich.de>
+
+pkgname="shallow-appify"
+pkgver="0.4.1"
+pkgrel="1"
+pkgdesc="Converts any executable to a non-self-contained mac app bundle which depends on system libraries."
+arch=("any")
+url="https://github.com/IngoHeimbach/shallow-appify"
+license=("MIT")
+depends=("python" "python-jinja" "python-pillow")
+makedepends=("python-setuptools")
+source=("https://github.com/IngoHeimbach/shallow-appify/archive/v${pkgver}.tar.gz")
+sha256sums=("1f0dc5fa855c7b171d1c94a4d39558a3371489ac8be79dc1cab8ae29f2576be3")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || return
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || return
+ python setup.py install --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}" \
+ --skip-build
+}