summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author“thayeeboi890”2023-12-18 18:43:40 -0600
committer“thayeeboi890”2023-12-18 18:47:01 -0600
commitb5197065983f0c48c53119858bf4cb2fce1d76ee (patch)
treef612eb70b9c7de4dd34edd12dfccfa567742aa8f
downloadaur-b5197065983f0c48c53119858bf4cb2fce1d76ee.tar.gz
create aur
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD51
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ace6fd23cc00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ShAm
+ pkgdesc = shell script compiler
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/neolabs-software/sham
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = gcc
+ source = ShAm-3.0.0.tar.gz::https://github.com/NEOLabs-software/ShAm/archive/refs/tags/3.0.0.tar.gz
+ md5sums = 59051b9d8374b79fd1875d1558c47b1b ShAm-3.0.0.tar.gz
+
+pkgname = ShAm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbf6355a5f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=ShAm
+pkgver=3.0.0
+pkgrel=1
+epoch=
+pkgdesc="shell script compiler"
+arch=(x86_64)
+url="https://github.com/neolabs-software/sham"
+license=('GPL')
+groups=()
+depends=(gcc)
+makedepends=(gcc)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/NEOLabs-software/ShAm/archive/refs/tags/3.0.0.tar.gz")
+noextract=()
+md5sums=('59051b9d8374b79fd1875d1558c47b1b')
+validpgpkeys=()
+
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ meson . build
+ ninja -C build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ ls build/sham
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR=$pkgdir/ ninja -C build install
+}