summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchisman Panigrahi2021-05-26 01:26:51 +0530
committerArchisman Panigrahi2021-05-26 01:30:29 +0530
commit7f7b2d7d8988f0b3b46569c1b179a31f824935b1 (patch)
treed8eb06c912a4e27f66ddb61252c4a258d06bfc7c
downloadaur-7f7b2d7d8988f0b3b46569c1b179a31f824935b1.tar.gz
First commit -v0.1.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb96c884474
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = share-preview
+ pkgdesc = Preview and debug websites metadata tags for social media share.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/rafaelmardojai/share-preview
+ arch = amd64
+ arch = aarch64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = meson
+ makedepends = rust
+ depends = gtk4
+ depends = libadwaita
+ depends = glib2
+ source = share-preview-0.1.1.tar.xz::https://github.com/rafaelmardojai/share-preview/releases/download/0.1.1/share-preview-0.1.1.tar.xz
+ sha256sums = 51492f70f3bdefc1e09e2074276b4d049e95ae9195120c6207e63c056fc60a22
+
+pkgname = share-preview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe86771d886c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Archisman Panigrahi <apandada1 at gmail dot com>
+pkgname=share-preview
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Preview and debug websites metadata tags for social media share."
+arch=('amd64' 'aarch64')
+url="https://github.com/rafaelmardojai/share-preview"
+license=('GPL3')
+depends=('gtk4' 'libadwaita' 'glib2')
+makedepends=('meson' 'rust')
+checkdepends=('appstream-glib')
+source=("$pkgname-$pkgver.tar.xz::$url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('51492f70f3bdefc1e09e2074276b4d049e95ae9195120c6207e63c056fc60a22')
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}