summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchisman Panigrahi2021-05-26 10:51:14 +0530
committerArchisman Panigrahi2021-05-26 18:22:12 +0530
commit0605724625c81d54fcc4230f47bfb1ac2e7e9869 (patch)
tree6a377e90e211eef5a527e2a8bbc5d53857ac69ac
downloadaur-0605724625c81d54fcc4230f47bfb1ac2e7e9869.tar.gz
create bin package for v0.1.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cca2764ffd47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = share-preview-bin
+ pkgdesc = Preview and debug websites metadata tags for social media share.
+ pkgver = 0.1.2
+ pkgrel = 2
+ url = https://github.com/rafaelmardojai/share-preview
+ arch = x86_64
+ license = GPL3
+ depends = gtk4
+ depends = libadwaita
+ depends = glib2
+ provides = share-preview
+ conflicts = share-preview
+ source = share-preview-bin-0.1.2.tar.gz::https://github.com/apandada1/share-preview/releases/download/0.1.2/-0.1.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = share-preview-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a16b1e6f94e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Archisman Panigrahi <apandada1 at gmail dot com>
+pkgname=share-preview-bin
+pkgver=0.1.2
+pkgrel=2
+pkgdesc="Preview and debug websites metadata tags for social media share."
+arch=('x86_64')
+url="https://github.com/rafaelmardojai/share-preview"
+license=('GPL3')
+provides=('share-preview')
+conflicts=('share-preview')
+depends=('gtk4' 'libadwaita' 'glib2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/apandada1/share-preview/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cp -r "$srcdir/usr/" "$pkgdir/"
+}