summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:41:34 +0200
committersmls2015-07-09 16:41:34 +0200
commit23489acc1095b019c3cdd2ddf5fc4ef5df65bf54 (patch)
tree468267bfce4c04baf7c592c3a8c26a3b14522436
downloadaur-23489acc1095b019c3cdd2ddf5fc4ef5df65bf54.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD67
-rw-r--r--shatter-hib.desktop11
-rw-r--r--shatter-hib.install9
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8a5c8e62848
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = shatter-hib
+ pkgdesc = A retro-inspired brick-breaking game with unique twists (Humble Bundle version)
+ pkgver = 1.0.20130609
+ pkgrel = 1
+ url = http://www.shattergame.com/
+ install = shatter-hib.install
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = lib32-libgl
+ depends = lib32-libidn
+ depends = lib32-libxinerama
+ depends = lib32-libxft
+ depends = lib32-alsa-lib
+ depends = xdg-utils
+ depends = lib32-nvidia-cg-toolkit
+ depends = lib32-libtxc_dxtn
+ optdepends = lib32-alsa-plugins: PulseAudio support
+ optdepends = lib32-libpulse: PulseAudio support
+ options = !upx
+ source = hib://Shatter-Release-2013-06-09.sh
+ source = shatter-hib.desktop
+ md5sums = 0c787b00292593ad91711c0df56ded0c
+ md5sums = 52e9ea073d699ae979167fd4cb4af585
+
+pkgname = shatter-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b23046905928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=shatter-hib
+pkgver=1.0.20130609
+_hibver=2013-06-09
+pkgrel=1
+pkgdesc='A retro-inspired brick-breaking game with unique twists (Humble Bundle version)'
+url='http://www.shattergame.com/'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+if [ $CARCH == i686 ]; then
+ depends=('libgl' 'libidn' 'libxinerama' 'libxft' 'alsa-lib' 'xdg-utils'
+ 'nvidia-cg-toolkit' 'libtxc_dxtn')
+ optdepends=('alsa-plugins: PulseAudio support'
+ 'libpulse: PulseAudio support')
+else
+ depends=('lib32-libgl' 'lib32-libidn' 'lib32-libxinerama' 'lib32-libxft'
+ 'lib32-alsa-lib' 'xdg-utils' 'lib32-nvidia-cg-toolkit'
+ 'lib32-libtxc_dxtn')
+ optdepends=('lib32-alsa-plugins: PulseAudio support'
+ 'lib32-libpulse: PulseAudio support')
+fi
+install='shatter-hib.install'
+options=('!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+_installer="Shatter-Release-$_hibver.sh"
+source=("hib://$_installer"
+ 'shatter-hib.desktop')
+md5sums=('0c787b00292593ad91711c0df56ded0c'
+ '52e9ea073d699ae979167fd4cb4af585')
+
+package() {
+ cd $srcdir
+ _installdir=/opt/Shatter; _target=$pkgdir/$_installdir
+
+ # Extract installer
+ mkdir -p $_target
+ while read line; do echo -n '.'; done < <( # show progress as dots
+ sh "$_installer" --tar xvf
+ lzma -d < instarchive_linux_all | tar xvf - -C $_target
+ lzma -d < instarchive_all | tar xvf - -C $_target
+ lzma -d < subarch | tar xvf -
+ ); echo
+
+ # Remove bundled libraries & helper binaries (use system packages instead)
+ rm -rf $pkgdir/opt/Shatter/lib/lib{Cg.so,CgGL.so,SDL-1.2.so.0}
+ rm -rf $pkgdir/opt/Shatter/{xdg-open,xdg-utils}
+
+ # Fix permissions
+ find $pkgdir -type f -exec chmod 644 "{}" +
+ chown root:root -R $pkgdir
+
+ # Install desktop entry & icon
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $_target/Shatter.png $pkgdir/usr/share/pixmaps/shatter.png
+
+ # Install launcher symlink
+ chmod 755 $_target/*.bin.x86
+ install -d $pkgdir/usr/bin
+ ln -s $_installdir/Shatter.bin.x86 $pkgdir/usr/bin/shatter
+ ln -s $_installdir/SettingsEditor.bin.x86 $pkgdir/usr/bin/shatter-settings
+
+ # Install license file
+ install -Dm644 config/license $pkgdir/usr/share/licenses/$pkgname/license
+}
diff --git a/shatter-hib.desktop b/shatter-hib.desktop
new file mode 100644
index 000000000000..dafe918751b0
--- /dev/null
+++ b/shatter-hib.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Shatter
+Comment=Sidhe Interactive
+GenericName=Brick-Breaking Game
+Icon=shatter
+Exec=/usr/bin/shatter
+Terminal=false
+StartupNotify=false
diff --git a/shatter-hib.install b/shatter-hib.install
new file mode 100644
index 000000000000..44f9832bf34c
--- /dev/null
+++ b/shatter-hib.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "Notes:#
+ echo " - Make sure the 32bit DRI drivers for your graphics card are"
+ echo " installed and working, otherwise the game will crash."
+ echo " - Before starting to play Shatter, you may want to run"
+ echo " `shatter-settings` in a terminal and increase the screen"
+ echo " resolution, choose your language, etc."
+}