summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2018-05-11 19:49:40 +0800
committerPeter Cai2018-05-11 19:49:40 +0800
commit15531f7a2942ced1635c407547362be293bb6a90 (patch)
treec037ff23ae299c2c34426abd900f69b9fd4505f5
downloadaur-15531f7a2942ced1635c407547362be293bb6a90.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--shattered-pixel-dungeon.desktop9
-rw-r--r--shattered-pixel-dungeon.sh3
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a286ea15cfa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = shattered-pixel-dungeon
+ pkgdesc = Shattered fork of the popular rogue-like game
+ pkgver = 0.6.3a
+ pkgrel = 1
+ url = http://shatteredpixel.tumblr.com
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = java-environment
+ depends = java-runtime
+ depends = bash
+ depends = xorg-xrandr
+ source = https://github.com/00-Evan/shattered-pixel-dungeon-gdx/archive/v0.6.3a.tar.gz
+ source = shattered-pixel-dungeon.sh
+ source = shattered-pixel-dungeon.desktop
+ sha512sums = fb4be8c9a5bfa96eea580c78a198140385caf9f6ad0f2914470c5a24dee29f4c3b5b90e00605f90414d35edfbfc08600247af063cdc5e1c8f03a053c5671a0f4
+ sha512sums = 88814d1f33eea6bd5656d3ca731ed5a6cfce10ecdae24012252c5b32c4b194ec75fb0e22cac70897802679086c6a32e210d52933ec45ca94ff350ac4ad7c266e
+ sha512sums = 204a7bcedbbc14bdad6586e4b759b326191a7fd2c344dadc7032495d4caa5fe32edac4118d7294229a6fe24f6684416fff37e260bbc9dde9e50846a03ba77db8
+
+pkgname = shattered-pixel-dungeon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..52003c53dd0a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..762b50d64ccd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Peter Cai <peter at typeblog dot net>
+# Thanks: Kevin MacMartin <prurigro at gmail dot com>
+
+pkgname=shattered-pixel-dungeon
+_pkgname=$pkgname-gdx
+pkgver=0.6.3a
+_srcdir=$_pkgname-$pkgver
+pkgrel=1
+pkgdesc='Shattered fork of the popular rogue-like game'
+url='http://shatteredpixel.tumblr.com'
+license=('GPL3')
+depends=('java-runtime' 'bash' 'xorg-xrandr')
+makedepends=('git' 'java-environment')
+arch=('any')
+source=(
+ "https://github.com/00-Evan/shattered-pixel-dungeon-gdx/archive/v$pkgver.tar.gz"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+)
+sha512sums=('fb4be8c9a5bfa96eea580c78a198140385caf9f6ad0f2914470c5a24dee29f4c3b5b90e00605f90414d35edfbfc08600247af063cdc5e1c8f03a053c5671a0f4'
+ '88814d1f33eea6bd5656d3ca731ed5a6cfce10ecdae24012252c5b32c4b194ec75fb0e22cac70897802679086c6a32e210d52933ec45ca94ff350ac4ad7c266e'
+ '204a7bcedbbc14bdad6586e4b759b326191a7fd2c344dadc7032495d4caa5fe32edac4118d7294229a6fe24f6684416fff37e260bbc9dde9e50846a03ba77db8')
+
+build() {
+ cd $_srcdir
+ unset _JAVA_OPTIONS
+ GRADLE_USER_HOME="$srcdir" ./gradlew desktop:dist
+}
+
+package() {
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 $_srcdir/android/res/drawable-xxxhdpi/ic_launcher.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 $_srcdir/desktop/build/libs/desktop-*.jar "$pkgdir/usr/share/$pkgname/$pkgname.jar"
+}
diff --git a/shattered-pixel-dungeon.desktop b/shattered-pixel-dungeon.desktop
new file mode 100644
index 000000000000..8bbb4b6a4222
--- /dev/null
+++ b/shattered-pixel-dungeon.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Shattered Pixel Dungeon
+Comment=Shattered fork of the popular rogue-like game
+Exec=shattered-pixel-dungeon
+Icon=shattered-pixel-dungeon
+Terminal=false
+Categories=Game;
diff --git a/shattered-pixel-dungeon.sh b/shattered-pixel-dungeon.sh
new file mode 100644
index 000000000000..938a4fcf64d7
--- /dev/null
+++ b/shattered-pixel-dungeon.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+
+java -jar /usr/share/shattered-pixel-dungeon/shattered-pixel-dungeon.jar