summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2022-01-11 11:51:42 -0500
committerKevin MacMartin2022-01-11 11:51:42 -0500
commit7ce04118ef24f1cf0e6b64d3d5804c1598caedec (patch)
treee890ab1c53a5e94be74ec9ef54096b1b8defefb3
parent0c948ecaf3fe955d8b2ea404eca1832a5680f62f (diff)
downloadaur-7ce04118ef24f1cf0e6b64d3d5804c1598caedec.tar.gz
Update to 5144v1.1.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--fix-build.patch17
3 files changed, 29 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36f6fa41b2ac..79fd47d44aca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shattered-pixel-dungeon-git
pkgdesc = Shattered fork of the popular rogue-like game
- pkgver = 5006v1.0.3
+ pkgver = 5144v1.1.1
pkgrel = 1
url = https://shatteredpixel.com
arch = any
@@ -12,8 +12,10 @@ pkgbase = shattered-pixel-dungeon-git
source = shattered-pixel-dungeon::git+https://github.com/00-Evan/shattered-pixel-dungeon.git
source = shattered-pixel-dungeon.sh
source = shattered-pixel-dungeon.desktop
+ source = fix-build.patch
sha512sums = SKIP
sha512sums = 88814d1f33eea6bd5656d3ca731ed5a6cfce10ecdae24012252c5b32c4b194ec75fb0e22cac70897802679086c6a32e210d52933ec45ca94ff350ac4ad7c266e
sha512sums = 204a7bcedbbc14bdad6586e4b759b326191a7fd2c344dadc7032495d4caa5fe32edac4118d7294229a6fe24f6684416fff37e260bbc9dde9e50846a03ba77db8
+ sha512sums = 2abddbb6e8e46045c406e3728cf0a616db279d807a129b860d86e692be97943052e0dffb9e30b051c0a99db9a13629913f411f887fe1a02b04fa9b2bf54d3d26
pkgname = shattered-pixel-dungeon-git
diff --git a/PKGBUILD b/PKGBUILD
index d650f5b48e79..d0110d4327a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=shattered-pixel-dungeon
pkgname=$_pkgname-git
-pkgver=5006v1.0.3
+pkgver=5144v1.1.1
pkgrel=1
pkgdesc='Shattered fork of the popular rogue-like game'
url='https://shatteredpixel.com'
@@ -18,12 +18,14 @@ source=(
"$_pkgname::git+https://github.com/00-Evan/shattered-pixel-dungeon.git"
"$_pkgname.sh"
"$_pkgname.desktop"
+ 'fix-build.patch'
)
sha512sums=(
'SKIP'
'88814d1f33eea6bd5656d3ca731ed5a6cfce10ecdae24012252c5b32c4b194ec75fb0e22cac70897802679086c6a32e210d52933ec45ca94ff350ac4ad7c266e'
'204a7bcedbbc14bdad6586e4b759b326191a7fd2c344dadc7032495d4caa5fe32edac4118d7294229a6fe24f6684416fff37e260bbc9dde9e50846a03ba77db8'
+ '2abddbb6e8e46045c406e3728cf0a616db279d807a129b860d86e692be97943052e0dffb9e30b051c0a99db9a13629913f411f887fe1a02b04fa9b2bf54d3d26'
)
pkgver() {
@@ -32,8 +34,13 @@ pkgver() {
}
prepare() {
+ cd "$_pkgname"
+
# Make the gradlew script executable
- chmod 755 "$_pkgname/gradlew"
+ chmod 755 gradlew
+
+ # Fix the build
+ patch -p1 < ../fix-build.patch
}
build() {
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..600a03392897
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,17 @@
+diff --git a/gradle.properties b/gradle.properties
+index 7cae816c4..0fbc8af10 100644
+--- a/gradle.properties
++++ b/gradle.properties
+@@ -4,9 +4,9 @@
+ # Specifies the JVM arguments used for the daemon process.
+ # The setting is particularly useful for tweaking memory settings.
+ # Default value: -Xmx1024m -XX:MaxPermSize=256m
+-org.gradle.jvmargs=-Xmx2048m -XX:MaxPermSize=512m -XX:+HeapDumpOnOutOfMemoryError -Dfile.encoding=UTF-8
++org.gradle.jvmargs=-Xmx2048m -XX:+HeapDumpOnOutOfMemoryError -Dfile.encoding=UTF-8
+ #
+ # When configured, Gradle will run in incubating parallel mode.
+ # This option should only be used with decoupled projects. More details, visit
+ # http://www.gradle.org/docs/current/userguide/multi_project_builds.html#sec:decoupled_projects
+-org.gradle.parallel=true
+\ No newline at end of file
++org.gradle.parallel=true