summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-09-09 16:47:43 +0200
committerDavide Depau2019-09-09 16:47:43 +0200
commit79e008bde31cde9647bfa8b59e7617c618c14228 (patch)
tree2b5742f09dbc98f4d783238ea10104d583e81c86
downloadaur-79e008bde31cde9647bfa8b59e7617c618c14228.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c720f88ed58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = shcrt-git
+ pkgdesc = Replace proprietary SecureCRT software with a Bash script that parses its configs
+ pkgver = r23.bd960a6
+ pkgrel = 1
+ url = https://github.com/Depau/shcrt
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = easybashgui
+ depends = python
+ depends = python-pycrypto
+ provides = shcrt
+ conflicts = shcrt
+ source = shcrt::git+https://github.com/Depau/shcrt.git
+ sha256sums = SKIP
+
+pkgname = shcrt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d26cf3c882e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Davide Depau <davide@depau.eu>
+
+_pkgname=shcrt
+pkgname=$_pkgname-git
+pkgver=r23.bd960a6
+pkgrel=1
+pkgdesc="Replace proprietary SecureCRT software with a Bash script that parses its configs"
+arch=('any')
+depends=('bash' 'easybashgui' 'python' 'python-pycrypto')
+url="https://github.com/Depau/shcrt"
+license=('GPL3')
+source=(${_pkgname}::git+https://github.com/Depau/shcrt.git)
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ install -dm755 "$pkgdir/usr/share/shcrt"
+ install -m755 shcrt "$pkgdir/usr/share/shcrt/shcrt"
+ install -m755 crt2foss.py "$pkgdir/usr/share/shcrt/crt2foss.py"
+ install -m755 SecureCRTCipher.py "$pkgdir/usr/share/shcrt/SecureCRTCipher.py"
+
+ install -dm755 "$pkgdir/usr/bin"
+ ln -sf /usr/share/shcrt/shcrt "$pkgdir/usr/bin/shcrt"
+ ln -sf /usr/share/shcrt/crt2foss.py "$pkgdir/usr/bin/crt2foss"
+ ln -sf /usr/share/shcrt/SecureCRTCipher.py "$pkgdir/usr/bin/SecureCRTCipher.py"
+}