summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-03-02 00:58:37 +0100
committerDaniel Peukert2023-03-02 00:58:37 +0100
commitb090f1b0d8208a26423973af227edd08409fd2ec (patch)
treef3814c8de970e7ca997066dbd9906de75a529e40
parentd99fff486788cafe955474f174d60112c867619e (diff)
downloadaur-b090f1b0d8208a26423973af227edd08409fd2ec.tar.gz
Fix shd segfault and update architectures
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed2c6f820c04..e68b71c98257 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = shd-git
pkgdesc = Console tool to display drive list with commonly checked smart info - git version
- pkgver = 0.1.3.r2.g8c68335
+ pkgver = 0.1.4.r6.g7c05853
pkgrel = 1
url = https://github.com/alttch/shd
arch = x86_64
arch = i686
- arch = arm
+ arch = armv7h
arch = aarch64
license = MIT
makedepends = cargo
makedepends = git
- depends = smartmontools
+ depends = smartmontools>=7.0
provides = shd
conflicts = shd
source = shd-git::git+https://github.com/alttch/shd
diff --git a/PKGBUILD b/PKGBUILD
index 5f2f9d124949..fe73ec60df5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='shd'
pkgname="$_pkgname-git"
-pkgver='0.1.3.r2.g8c68335'
+pkgver='0.1.4.r6.g7c05853'
pkgrel='1'
pkgdesc='Console tool to display drive list with commonly checked smart info - git version'
-arch=('x86_64' 'i686' 'arm' 'aarch64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/alttch/$_pkgname"
license=('MIT')
-depends=('smartmontools')
+depends=('smartmontools>=7.0')
makedepends=('cargo' 'git')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -22,11 +22,10 @@ prepare() {
# Prepare correct target for our architecture
_cargotarget="$CARCH-unknown-linux-musl"
- if [ "$CARCH" = 'arm' ]; then
- _cargotarget="${_cargotarget}eabihf"
+ if [ "$CARCH" = 'armv7h' ]; then
+ _cargotarget='armv7-unknown-linux-musleabihf'
fi
- cargo update
cargo fetch --locked --target "$_cargotarget"
}
@@ -38,12 +37,12 @@ pkgver() {
build() {
cd "$srcdir/$_sourcedirectory/"
export RUSTUP_TOOLCHAIN='stable'
- export CARGO_TARGET_DIR='build'
+ export CARGO_TARGET_DIR='target'
cargo build --frozen --release --all-features
}
package() {
cd "$srcdir/$_sourcedirectory/"
- install -Dm755 "build/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}