summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-04-04 05:36:06 +0200
committerMichal Wojdyla2024-04-04 05:36:06 +0200
commit81f651c806c8b16a60d4be023a90e32784507294 (patch)
tree92c4c103e26547dbe432134c051331f87ddbef1f
parent6a96a14132ca81957671df7a3286a9d89e7df980 (diff)
downloadaur-81f651c806c8b16a60d4be023a90e32784507294.tar.gz
use python3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56719dd1003d..81bd9e757199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = shedskin-git
pkgdesc = Experimental (restricted) Python-to-C++ compiler (development version)
- pkgver = 0.9.4.r120.gae88dbca
+ pkgver = 0.9.8.r68.g937e8196
pkgrel = 1
url = https://github.com/shedskin/shedskin
arch = any
license = GPL3
makedepends = git
+ makedepends = python-setuptools
depends = pcre
depends = gc
- depends = python2
+ depends = python
provides = shedskin
conflicts = shedskin
source = git+https://github.com/shedskin/shedskin.git
diff --git a/PKGBUILD b/PKGBUILD
index 6229274ca480..0a82412dd3a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Alexander Rødseth <rodseth@gmail.com>
pkgname=shedskin-git
-pkgver=0.9.4.r120.gae88dbca
+pkgver=0.9.8.r68.g937e8196
pkgrel=1
pkgdesc='Experimental (restricted) Python-to-C++ compiler (development version)'
url='https://github.com/shedskin/shedskin'
@@ -11,8 +11,8 @@ license=('GPL3')
source=(git+https://github.com/shedskin/shedskin.git)
sha256sums=('SKIP')
arch=('any')
-depends=('pcre' 'gc' 'python2')
-makedepends=('git')
+depends=('pcre' 'gc' 'python')
+makedepends=('git' 'python-setuptools')
conflicts=('shedskin')
provides=('shedskin')
@@ -23,23 +23,16 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd shedskin
-
- # Patch Python versions.
- sed -i -e 's/python\b/python2/g' $(grep -rl 'python\b')
-}
-
build() {
cd shedskin
# Build it!
- python2 setup.py build
+ python setup.py build
}
package() {
cd shedskin
# Install the program.
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1
}