summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeoffrey Frogeye2016-05-29 19:44:44 +0200
committerGeoffrey Frogeye2016-05-29 19:44:44 +0200
commit39f3e46bbbb049bc839451224437f48e1747a727 (patch)
treeb0d505bafef63ae616efe7d5bbad167b353a669b
downloadaur-39f3e46bbbb049bc839451224437f48e1747a727.tar.gz
Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD44
-rw-r--r--sheepit-client.conf35
-rw-r--r--sheepit-client.install4
-rw-r--r--sheepit-client.service13
-rwxr-xr-xsheepit-client.sh2
-rw-r--r--sheepit-client.sysusers1
7 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfd66f7b9a18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Sun May 29 17:43:42 UTC 2016
+pkgbase = sheepit-client-git
+ pkgdesc = Client for the free and distributed render farm
+ pkgver = 3.3.2r200.358ec13
+ pkgrel = 1
+ url = https://www.sheepit-renderfarm.com/
+ install = sheepit-client.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = apache-ant
+ depends = java-runtime
+ depends = freetype2
+ depends = glew
+ provides = sheepit-client
+ conflicts = sheepit-client
+ backup = etc/conf.d/sheepit-client
+ source = git://github.com/laurent-clouet/sheepit-client.git#branch=master
+ source = sheepit-client.sh
+ source = sheepit-client.sysusers
+ source = sheepit-client.conf
+ source = sheepit-client.service
+ md5sums = SKIP
+ md5sums = a30b3ba1c40b2063ccab54b65a7b8e09
+ md5sums = ade86db2b906f3468e014b28ebdd36d6
+ md5sums = 7ffbac5dffd3ffcf04ffba3c0c1f5bd2
+ md5sums = de9bc913315eee47c88b119e49279771
+
+pkgname = sheepit-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65d1efeac56f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Geoffrey Frogeye <geoffrey@frogeye.fr>
+
+pkgname=sheepit-client-git
+pkgver=3.3.2r200.358ec13
+pkgrel=1
+pkgdesc="Client for the free and distributed render farm"
+arch=('i686' 'x86_64')
+url="https://www.sheepit-renderfarm.com/"
+license=('GPL')
+depends=('java-runtime' 'freetype2' 'glew')
+makedepends=('git' 'apache-ant')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=sheepit-client.install
+backup=('etc/conf.d/sheepit-client')
+source=('git://github.com/laurent-clouet/sheepit-client.git#branch=master'
+ 'sheepit-client.sh'
+ 'sheepit-client.sysusers'
+ 'sheepit-client.conf'
+ 'sheepit-client.service')
+md5sums=('SKIP'
+ 'a30b3ba1c40b2063ccab54b65a7b8e09'
+ 'ade86db2b906f3468e014b28ebdd36d6'
+ '7ffbac5dffd3ffcf04ffba3c0c1f5bd2'
+ 'de9bc913315eee47c88b119e49279771')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%sr%s.%s" "$(grep 'name="compile.release"' build.xml | cut -d '"' -f 4)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ant
+}
+
+package() {
+ install -Dm644 "${srcdir}/${pkgname%-git}/bin/sheepit-client.jar" "${pkgdir}/usr/share/java/sheepit-client/sheepit-client.jar"
+ install -Dm755 "${srcdir}/sheepit-client.sh" "${pkgdir}/usr/bin/sheepit-client"
+ install -Dm644 "${srcdir}/sheepit-client.sysusers" "${pkgdir}/usr/lib/sysusers.d/sheepit-client.conf"
+ install -Dm644 "${srcdir}/sheepit-client.conf" "${pkgdir}/etc/conf.d/sheepit-client"
+ install -Dm644 "${srcdir}/sheepit-client.service" "${pkgdir}/usr/lib/systemd/system/sheepit-client.service"
+}
+
diff --git a/sheepit-client.conf b/sheepit-client.conf
new file mode 100644
index 000000000000..67738d9cd30a
--- /dev/null
+++ b/sheepit-client.conf
@@ -0,0 +1,35 @@
+# Cache/Working directory. Caution,
+# everything in it not related to the
+# render-farm will be removed
+cache-dir=
+# cache-dir=/var/lib/sheepit-client/
+
+# CPU: only use cpu, GPU: only use gpu,
+# CPU_GPU: can use cpu and gpu (not at
+# the same time) if gpu is not use it
+# will not use the gpu
+compute-method=CPU
+
+# CUDA name of the GPU used for the
+# render, for example CUDA_0
+#compute-gpu=CUDA_0
+
+# Number of cores/threads to use for
+# the render
+#cpu-cores=4
+
+# User's login
+login=
+
+# User's password or public key
+password=
+
+# URL of the proxy
+proxy=
+# proxy=http://login:password@host:port
+
+# Specify the user interface to use,
+# default 'swing', available 'oneLine',
+# 'text', 'swing' (graphical)
+ui=text
+
diff --git a/sheepit-client.install b/sheepit-client.install
new file mode 100644
index 000000000000..ef6ab2c0657d
--- /dev/null
+++ b/sheepit-client.install
@@ -0,0 +1,4 @@
+post_install() {
+ systemd-sysusers sheepit-client.conf
+ [[ -d /var/lib/sheepit-client ]] || install -dm 700 -o sheepit-client -g sheepit-client /var/lib/sheepit-client
+}
diff --git a/sheepit-client.service b/sheepit-client.service
new file mode 100644
index 000000000000..66d46202d3a3
--- /dev/null
+++ b/sheepit-client.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Client for the free and distributed render farm SheepIt
+Documentation=https://www.sheepit-renderfarm.com/
+After=network.target
+
+[Service]
+User=sheepit
+ExecStart=/usr/bin/sheepit-client -config /etc/conf.d/sheepit-client
+RestartSec=10
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sheepit-client.sh b/sheepit-client.sh
new file mode 100755
index 000000000000..aaa26cd19ecb
--- /dev/null
+++ b/sheepit-client.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/java -jar '/usr/share/java/sheepit-client/sheepit-client.jar' "$@"
diff --git a/sheepit-client.sysusers b/sheepit-client.sysusers
new file mode 100644
index 000000000000..6b4c2a60a6aa
--- /dev/null
+++ b/sheepit-client.sysusers
@@ -0,0 +1 @@
+u sheepit-client - "SheepIt client user" /var/lib/sheepit-client