summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-09-22 13:54:52 +0200
committerAlexander F Rødseth2016-09-22 13:54:52 +0200
commit0653ba57a06f6442c5164ef8c9dfe7803d3440f0 (patch)
treeb2636b436533613b8adbbbb6ee0b16912c3893f6
parent6984b22ce342f001a50e0d75b83ca18a6e80ffbf (diff)
downloadaur-0653ba57a06f6442c5164ef8c9dfe7803d3440f0.tar.gz
Update URL and dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 347235782a8b..1b78e88ee255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Sep 22 11:54:45 UTC 2016
pkgbase = sheeplifter
pkgdesc = Control a wolf in a spaceship and abduct sheep in 3D (arcade game)
pkgver = 2
- pkgrel = 5
+ pkgrel = 6
url = http://code.google.com/p/sheeplifter/
arch = x86_64
arch = i686
license = BSD
makedepends = gendesk
depends = java-runtime
- depends = lwjgl
- source = http://sheeplifter.googlecode.com/files/Sheeplifter_GC_2.zip
+ depends = lwjgl2
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sheeplifter/Sheeplifter_GC_2.zip
source = sheeplifter.png
source = run.sh
sha256sums = 0d35701e538b8a6c61e6940dae63d222c6df799e60958bdfd2bd0199aba5c527
diff --git a/PKGBUILD b/PKGBUILD
index 3cea29575775..927267ff7abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,42 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
pkgname=sheeplifter
pkgver=2
-pkgrel=5
-pkgdesc="Control a wolf in a spaceship and abduct sheep in 3D (arcade game)"
-url="http://code.google.com/p/sheeplifter/"
+pkgrel=6
+pkgdesc='Control a wolf in a spaceship and abduct sheep in 3D (arcade game)'
+url='http://code.google.com/p/sheeplifter/'
license=('BSD')
arch=('x86_64' 'i686')
-depends=('java-runtime' 'lwjgl')
+depends=('java-runtime' 'lwjgl2')
makedepends=('gendesk')
-source=('http://sheeplifter.googlecode.com/files/Sheeplifter_GC_2.zip'
+source=('https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sheeplifter/Sheeplifter_GC_2.zip'
'sheeplifter.png'
'run.sh')
sha256sums=('0d35701e538b8a6c61e6940dae63d222c6df799e60958bdfd2bd0199aba5c527'
'15c09faf8ee47847dda8071853639663bd09b8fcc638ce599398d7beb103e5c7'
'ca257e05e4849cc215120923d656f6e43fdea7cc280009fc92b02c902db52f63')
-build() {
- cd "$srcdir"
- gendesk -n
+prepare() {
cd "$pkgname"
- tail -24 readme.txt > license.txt
+
+ gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc"
+ tail -24 readme.txt > COPYING
}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/share/"{pixmaps,applications,sheeplifter} \
- "$pkgdir/usr/bin"
+ cd "$pkgname"
+
+ install -d "$pkgdir/usr/share/"{pixmaps,applications,sheeplifter} "$pkgdir/usr/bin"
cp -R jme "$pkgdir/usr/share/sheeplifter"
cp -R jorbis "$pkgdir/usr/share/sheeplifter"
- find $pkgdir/usr/share/sheeplifter -type f -exec chmod 644 {} \;
- install -Dm644 readme.txt sheeplifter.jar $pkgdir/usr/share/sheeplifter
- install -Dm755 run_game_linux.sh $pkgdir/usr/share/sheeplifter
- install -Dm644 license.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
+ find "$pkgdir/usr/share/sheeplifter" -type f -exec chmod 644 {} \;
+ install -Dm644 readme.txt sheeplifter.jar "$pkgdir/usr/share/sheeplifter"
+ install -Dm755 run_game_linux.sh "$pkgdir/usr/share/sheeplifter"
+ install -Dm644 sheeplifter.desktop "$pkgdir/usr/share/applications"
+ install -Dm644 ../sheeplifter.png "$pkgdir/usr/share/pixmaps"
install -Dm755 ../run.sh "$pkgdir/usr/bin/sheeplifter"
- install -Dm644 ../sheeplifter.png $pkgdir/usr/share/pixmaps
- install -Dm644 ../sheeplifter.desktop $pkgdir/usr/share/applications
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
# vim:set ts=2 sw=2 et: