summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2020-10-13 13:20:35 +0200
committerAntoine Viallon2020-10-13 13:20:35 +0200
commit4df24403b97d87b0f6da62072f40eff9275c17da (patch)
treec6bbbdd23e913b50c9655482118d99d20c6b9ef9
parent006196fd54c90883054218e2294c23de171a2d2b (diff)
downloadaur-4df24403b97d87b0f6da62072f40eff9275c17da.tar.gz
Fix sheepshaver build
Remove outdated configure flags Remove -j1, since building works without
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--sdl2_bug.patch25
-rw-r--r--unsigned_bug.patch23
4 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551df54a6389..adaf4bd55872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sheepshaver-git
pkgdesc = An Open Source PowerMac Emulator
- pkgver = r2619.gcbad6f95
- pkgrel = 2
+ pkgver = r2660.g29bb3d5a
+ pkgrel = 1
url = http://sheepshaver.cebix.net
arch = x86_64
license = GPL
@@ -12,19 +12,19 @@ pkgbase = sheepshaver-git
source = SheepShaver.sysctl
source = SheepShaver.desktop
source = SheepShaver.png
- source = unsigned_bug.patch
+ source = sdl2_bug.patch
sha256sums = SKIP
sha256sums = a4aa858b95d29906873693988d5db42d5a4da8aa94a72c79374f59fc488efd51
sha256sums = cb002e73e864a6ca271e0bbaa6df6eb89dc1df86856fc575c20bf79367458c39
sha256sums = b7f67b1f8424f3e0ffa1a5e57597f368c4c4f93ea1f871ec0a76700b7519b241
- sha256sums = 1702ef4c5ea4459268653ea7a2a76d2b3e60a9e4b17c64ea9818869124539e49
+ sha256sums = ab944b2d074df35671ad534a1c768fdcf663d9d0f838d68b73007e3737b1a0c4
pkgname = sheepshaver-git
- provides = sheepshaver=r2619.gcbad6f95
+ provides = sheepshaver=r2660.g29bb3d5a
conflicts = sheepshaver
pkgname = sheepnet-dkms-git
depends = dkms
- provides = sheepnet-dkms=r2619.gcbad6f95
+ provides = sheepnet-dkms=r2660.g29bb3d5a
conflicts = sheepnet-dkms
diff --git a/PKGBUILD b/PKGBUILD
index bf14b686f65a..ca07f235c958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=sheepshaver-git
pkgname=(sheepshaver-git sheepnet-dkms-git)
-pkgver=r2619.gcbad6f95
-pkgrel=2
+pkgver=r2660.g29bb3d5a
+pkgrel=1
pkgdesc="An Open Source PowerMac Emulator"
arch=('x86_64')
url="http://sheepshaver.cebix.net"
@@ -13,12 +13,12 @@ source=('git+https://github.com/cebix/macemu'
'SheepShaver.sysctl'
'SheepShaver.desktop'
'SheepShaver.png'
- 'unsigned_bug.patch')
+ 'sdl2_bug.patch')
sha256sums=('SKIP'
'a4aa858b95d29906873693988d5db42d5a4da8aa94a72c79374f59fc488efd51'
'cb002e73e864a6ca271e0bbaa6df6eb89dc1df86856fc575c20bf79367458c39'
'b7f67b1f8424f3e0ffa1a5e57597f368c4c4f93ea1f871ec0a76700b7519b241'
- '1702ef4c5ea4459268653ea7a2a76d2b3e60a9e4b17c64ea9818869124539e49')
+ 'ab944b2d074df35671ad534a1c768fdcf663d9d0f838d68b73007e3737b1a0c4')
pkgver() {
cd macemu
@@ -27,7 +27,7 @@ pkgver() {
prepare() {
cd macemu/
- #patch -p1 -i "$srcdir/unsigned_bug.patch" # patch merged upstream
+ patch -p1 -i "$srcdir/sdl2_bug.patch"
}
build() {
@@ -39,11 +39,9 @@ build() {
--enable-sdl-audio \
--enable-addressing=real \
--enable-sdl-video \
- --enable-tuntap \
--with-bincue \
- --with-vdeplug \
- ;
- make -j1
+ ;
+ make
}
package_sheepshaver-git() {
diff --git a/sdl2_bug.patch b/sdl2_bug.patch
new file mode 100644
index 000000000000..5506e913e339
--- /dev/null
+++ b/sdl2_bug.patch
@@ -0,0 +1,25 @@
+From b7bf5f6422f60e863051d1cfa3f067cd028a0bf8 Mon Sep 17 00:00:00 2001
+From: Darren Blaber <dmbtech@gmail.com>
+Date: Sat, 1 Aug 2020 17:54:23 -0400
+Subject: [PATCH] Fix configure.ac so sheepshaver builds with sdl2 changes
+
+ENABLE_SDL1 must be set after commit https://github.com/cebix/macemu/commit/a46759990d33d7d1e2c7bac01459747d6180eb76 or else
+symbols in video_sdl.cpp(VideoExit(), VideoInit() etc) will not be available, when building sheepshaver with
+--enable-sdl-video. Sheepshaver and BasiliskII share the same SDL code,
+so this must be changed as well.
+---
+ SheepShaver/src/Unix/configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/SheepShaver/src/Unix/configure.ac b/SheepShaver/src/Unix/configure.ac
+index 006fe872..cb3baa0a 100644
+--- a/SheepShaver/src/Unix/configure.ac
++++ b/SheepShaver/src/Unix/configure.ac
+@@ -195,6 +195,7 @@ if [[ "x$WANT_SDL" = "xyes" ]]; then
+ fi
+ if [[ "x$ac_cv_framework_SDL" = "xno" ]]; then
+ AC_PATH_PROG(sdl_config, "sdl-config")
++ AC_DEFINE(ENABLE_SDL1, 1, [Define if using SDL1, sheepshaver only currenly supports 1.])
+ if [[ -n "$sdl_config" ]]; then
+ sdl_cflags=`$sdl_config --cflags`
+ if [[ "x$WANT_SDL_STATIC" = "xyes" ]]; then
diff --git a/unsigned_bug.patch b/unsigned_bug.patch
deleted file mode 100644
index 336476ab4b1c..000000000000
--- a/unsigned_bug.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From f13f25db3e952cd40b3c3aa90a24399408968e04 Mon Sep 17 00:00:00 2001
-From: Antoine Viallon <antoine@lesviallon.fr>
-Date: Sat, 20 Jun 2020 19:19:49 +0200
-Subject: [PATCH] Fix build fail under GCC 10
-
-GCC fails to build because of -Wnarrowing
----
- SheepShaver/src/video.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/SheepShaver/src/video.cpp b/SheepShaver/src/video.cpp
-index d0eda93d..60ef8c13 100644
---- a/SheepShaver/src/video.cpp
-+++ b/SheepShaver/src/video.cpp
-@@ -736,7 +736,7 @@ static int16 VideoStatus(uint32 pb, VidLocals *csSave)
-
- case cscGetNextResolution: {
- D(bug("GetNextResolution \n"));
-- int work_id = ReadMacInt32(param + csPreviousDisplayModeID);
-+ unsigned int work_id = ReadMacInt32(param + csPreviousDisplayModeID);
- switch (work_id) {
- case kDisplayModeIDCurrent:
- work_id = csSave->saveData;