summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric DeStefano2018-09-08 17:10:17 +0200
committerEric DeStefano2018-09-08 17:10:17 +0200
commit71b06bb70830170ed196e3b326d7cbaecbd673dc (patch)
tree40af62b93e11d0250cbe5b889187e6c5c2ab3fa5
downloadaur-71b06bb70830170ed196e3b326d7cbaecbd673dc.tar.gz
First commit to upload SheepShaver for Arch Linux
-rw-r--r--.SRCINFO22
-rw-r--r--99-sheepshaver.conf1
-rw-r--r--PKGBUILD38
-rw-r--r--SheepShaver.desktop10
-rw-r--r--SheepShaver.pngbin0 -> 2129 bytes
-rw-r--r--sheepshaver.install25
6 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05ac9c24b370
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sheepshaver
+ pkgdesc = An Open Source PowerMac Emulator
+ pkgver = 2e302d6
+ pkgrel = 1
+ url = http://sheepshaver.cebix.net
+ install = sheepshaver.install
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = sdl
+ provides = sheepshaver
+ source = https://github.com/cebix/macemu/zipball/master/cebix-macemu-2e302d6.zip
+ source = 99-sheepshaver.conf
+ source = SheepShaver.desktop
+ source = SheepShaver.png
+ sha256sums = ebad98765ece1756e76f5a9d42b8560340b98bb458080bba173472362658454a
+ sha256sums = a4aa858b95d29906873693988d5db42d5a4da8aa94a72c79374f59fc488efd51
+ sha256sums = cb002e73e864a6ca271e0bbaa6df6eb89dc1df86856fc575c20bf79367458c39
+ sha256sums = b7f67b1f8424f3e0ffa1a5e57597f368c4c4f93ea1f871ec0a76700b7519b241
+
+pkgname = sheepshaver
+
diff --git a/99-sheepshaver.conf b/99-sheepshaver.conf
new file mode 100644
index 000000000000..84c8a7d85dc3
--- /dev/null
+++ b/99-sheepshaver.conf
@@ -0,0 +1 @@
+vm.mmap_min_addr=0
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1da94db089dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Eric DeStefano <eric at ericdestefano dot com>
+
+pkgname=sheepshaver
+pkgver=2e302d6
+pkgrel=1
+pkgdesc="An Open Source PowerMac Emulator"
+arch=('x86_64')
+url="http://sheepshaver.cebix.net"
+license=('GPL')
+depends=('gtk2' 'sdl')
+provides=('sheepshaver')
+install=$pkgname.install
+source=('https://github.com/cebix/macemu/zipball/master/cebix-macemu-2e302d6.zip'
+'99-sheepshaver.conf'
+'SheepShaver.desktop'
+'SheepShaver.png')
+sha256sums=('ebad98765ece1756e76f5a9d42b8560340b98bb458080bba173472362658454a'
+'a4aa858b95d29906873693988d5db42d5a4da8aa94a72c79374f59fc488efd51'
+'cb002e73e864a6ca271e0bbaa6df6eb89dc1df86856fc575c20bf79367458c39'
+'b7f67b1f8424f3e0ffa1a5e57597f368c4c4f93ea1f871ec0a76700b7519b241')
+
+build() {
+ cd $srcdir/cebix-macemu-$pkgver/SheepShaver/src/Unix
+ ./autogen.sh --prefix=/usr --enable-sdl-audio --enable-sdl-video --with-bincue
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/cebix-macemu-$pkgver/SheepShaver/src/Unix/SheepShaver" "${pkgdir}/usr/bin/SheepShaver"
+ mkdir -p ${pkgdir}/etc/sysctl.d
+ install -Dm644 "$srcdir/99-sheepshaver.conf" "${pkgdir}/etc/sysctl.d/"
+ mkdir -p ${pkgdir}/usr/share/doc
+ mkdir ${pkgdir}/usr/share/pixmaps
+ cp -a $srcdir/cebix-macemu-2e302d6/SheepShaver/doc/Linux $pkgdir/usr/share/SheepShaver
+ install -Dm644 ../SheepShaver.png $pkgdir/usr/share/pixmaps/SheepShaver.png
+ mkdir ${pkgdir}/usr/share/applications
+ install -Dm644 ../SheepShaver.desktop $pkgdir/usr/share/applications/SheepShaver.desktop
+}
diff --git a/SheepShaver.desktop b/SheepShaver.desktop
new file mode 100644
index 000000000000..010d8abfea95
--- /dev/null
+++ b/SheepShaver.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=2e302d6
+Name=SheepShaver
+Comment="An Open Source PowerMac Emulator"
+Icon=SheepShaver
+Exec=SheepShaver
+Terminal=false
+StartupNotify=false
+Categories=Emulator;Game;
diff --git a/SheepShaver.png b/SheepShaver.png
new file mode 100644
index 000000000000..1dd63d7dd516
--- /dev/null
+++ b/SheepShaver.png
Binary files differ
diff --git a/sheepshaver.install b/sheepshaver.install
new file mode 100644
index 000000000000..30e4a0049a0d
--- /dev/null
+++ b/sheepshaver.install
@@ -0,0 +1,25 @@
+post_install()
+{
+ echo ""
+ echo "***********************************************************************************"
+ echo " In order for SheepShaver to run, you must execute:"
+ echo " sudo sysctl vm.mmap_min_addr=0"
+ echo ""
+ echo " ...or reboot, and /etc/sysctl.d/99-sheepshaver.conf will take care of it for you."
+ echo "***********************************************************************************"
+ echo ""
+ echo ""
+ echo "******************************************************************************************"
+ echo " If you want networking support in SheepShaver, you'll need to build the kernel module."
+ echo " 1) Make sure linux-headers is installed with pacman"
+ echo " 2) cd src/cebix-macemu-2e302d6/SheepShaver/src/Unix/Linux/NetDriver"
+ echo " 3) Type: make"
+ echo " 4) Type: sudo make dev"
+ echo " 5) Type: sudo chown <your_username> /dev/sheep_net"
+ echo " 6) Type: sudo make install"
+ echo " 7) Type: sudo modprobe sheep_net"
+ echo "******************************************************************************************"
+ echo ""
+
+}
+