summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSabu Siyad2021-01-22 18:30:25 +0530
committerSabu Siyad2021-01-22 18:30:25 +0530
commita975f98703be715889731f5db9cfc9648f012707 (patch)
tree949350f3d3eeff7dcc9041f2a576e0304912d97c
downloadaur-a975f98703be715889731f5db9cfc9648f012707.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82334adbe461
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shelby-git
+ pkgdesc = A fast, lightweight, minimal, shell prompt written in Go
+ pkgver = r139.281761c
+ pkgrel = 1
+ url = https://github.com/athul/shelby
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ provides = shelby
+ conflicts = shelby-bin
+ source = git+https://github.com/athul/shelby.git
+ sha256sums = SKIP
+
+pkgname = shelby-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..427a7c897fb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+pkg/
+src/
+shelby*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce94a3bc875f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sabu Siyad <ssiyad at disroot dot org>
+
+pkgname=shelby-git
+_pkgname=shelby
+pkgver=r139.281761c
+pkgrel=1
+pkgdesc="A fast, lightweight, minimal, shell prompt written in Go"
+arch=('x86_64')
+url="https://github.com/athul/shelby"
+license=("GPL3")
+makedepends=("go")
+provides=("shelby")
+source=(
+ "git+https://github.com/athul/shelby.git"
+)
+sha256sums=("SKIP")
+conflicts=("shelby-bin")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -pv build/
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ go get -v
+ go build -o build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -D "build/${_pkgname}" "${pkgdir}/usr/local/bin/shelby"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}