summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordotiful2021-01-01 06:20:28 +0200
committerdotiful2021-01-01 06:20:28 +0200
commitf17704a05ec45c03cda5822e7bbfc2392c19789b (patch)
tree24ec475a028acd31a855ae3c427677973c578059
downloadaur-f17704a05ec45c03cda5822e7bbfc2392c19789b.tar.gz
version 0.6.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD23
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f07f11691262
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sheldon-bin
+ pkgdesc = A fast, configurable, shell plugin manager
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/rossmacarthur/sheldon
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ provides = sheldon
+ source = sheldon-v0.6.0.tar.gz::https://github.com/rossmacarthur/sheldon/releases/download/0.6.0/sheldon-0.6.0-x86_64-unknown-linux-musl.tar.gz
+ sha256sums = 2d9c55670c381daca92a3f5091864a827c34f62819965a0f1e9d9336f52b24c7
+
+pkgname = sheldon-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..509d8709b797
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c01faa05c611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Art Dev <artdevjs at gmail dot com>
+
+pkgname='sheldon-bin'
+_pkgname='sheldon'
+pkgver=0.6.0
+pkgrel=1
+pkgdesc='A fast, configurable, shell plugin manager '
+arch=('x86_64')
+url="https://github.com/rossmacarthur/sheldon"
+license=('MIT')
+depends=()
+makedepends=()
+provides=('sheldon')
+conflicts=('sheldon')
+source=(
+ "${_pkgname}-v${pkgver}.tar.gz::$url/releases/download/${pkgver}/${_pkgname}-${pkgver}-${CARCH}-unknown-linux-musl.tar.gz"
+)
+sha256sums=('2d9c55670c381daca92a3f5091864a827c34f62819965a0f1e9d9336f52b24c7')
+
+package() {
+ install -Dm755 "${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm644 "$srcdir/LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+}