summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 05:34:17 +0300
committerDimitris Kiziridis2020-05-15 05:34:17 +0300
commit3e4bb001be650f532cc2bb5aebb23436c1ead109 (patch)
tree766c5d19f1273cbdd21aa1ad3cbd18a05c10b4f0
parent3ae9f828c5dd1bd8ee138e844a1d59fdb5046edf (diff)
downloadaur-3e4bb001be650f532cc2bb5aebb23436c1ead109.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87f2d9e33486..d89b5ae032b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,10 @@ pkgbase = shell2http-bin
url = https://github.com/msoap/shell2http
arch = x86_64
license = MIT
+ depends = glibc
provides = shell2http
- source = https://github.com/msoap/shell2http/releases/download/1.13/shell2http-1.13.linux.amd64.tar.gz
- md5sums = 52a2274082ad504c9d0204dfd08d2324
+ source = shell2http-bin-1.13.tar.gz::https://github.com/msoap/shell2http/releases/download/1.13/shell2http-1.13.linux.amd64.tar.gz
+ sha256sums = 3da989b4022603e4a792cbeb7f356fe72a59a185d6a40adab48b656178888d4d
pkgname = shell2http-bin
diff --git a/PKGBUILD b/PKGBUILD
index c7acb576c595..adb8e1ca799d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@ pkgdesc='HTTP-server to execute shell commands'
arch=('x86_64')
url="https://github.com/msoap/shell2http"
license=('MIT')
+depends=('glibc')
provides=('shell2http')
-source=("https://github.com/msoap/shell2http/releases/download/${pkgver}/shell2http-${pkgver}.linux.amd64.tar.gz")
-md5sums=('52a2274082ad504c9d0204dfd08d2324')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/msoap/shell2http/releases/download/${pkgver}/shell2http-${pkgver}.linux.amd64.tar.gz")
+sha256sums=('3da989b4022603e4a792cbeb7f356fe72a59a185d6a40adab48b656178888d4d')
package() {
gzip --force "${srcdir}"/shell2http.1
install -Dm755 "${srcdir}"/shell2http "${pkgdir}/usr/bin/shell2http"
- install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/shell2http/LICENSE"
+ install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 shell2http.1.gz -t "${pkgdir}/usr/share/man/man1"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file