summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2022-09-14 01:52:13 +0300
committerDimitris Kiziridis2022-09-14 01:52:13 +0300
commitb96256acb6595ce423b2f1cba3cda7b6e024a185 (patch)
treeb00c406bf348f01003df39aedba826cbcbb9f76d
parentb469f0ba42b9231b4f19dd309a37350211545f1e (diff)
downloadaur-b96256acb6595ce423b2f1cba3cda7b6e024a185.tar.gz
Update to 1.14.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754314d7f600..e166a7756a12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = shell2http-bin
pkgdesc = HTTP-server to execute shell commands
- pkgver = 1.14.1
+ pkgver = 1.14.2
pkgrel = 1
url = https://github.com/msoap/shell2http
arch = x86_64
license = MIT
- depends = glibc
provides = shell2http
- source = shell2http-bin-1.14.1.tar.gz::https://github.com/msoap/shell2http/releases/download/v1.14.1/shell2http_1.14.1_linux_amd64.tar.gz
- sha256sums = cbd16aadcb627ae98630aa680407a53e79330f228a890f11b4a7ab4faf1b65e5
+ source = shell2http-bin-1.14.2.tar.gz::https://github.com/msoap/shell2http/releases/download/v1.14.2/shell2http_1.14.2_linux_amd64.tar.gz
+ sha256sums = 4708b1f89599f1bcd7aabd5e6a2843b2ed3580be207673b604f964b5d20cd3b5
pkgname = shell2http-bin
diff --git a/PKGBUILD b/PKGBUILD
index 83452a85d269..5a0389cb4f6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=shell2http-bin
-pkgver=1.14.1
+pkgver=1.14.2
pkgrel=1
pkgdesc='HTTP-server to execute shell commands'
arch=('x86_64')
url="https://github.com/msoap/shell2http"
license=('MIT')
-depends=('glibc')
provides=('shell2http')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/msoap/shell2http/releases/download/v${pkgver}/shell2http_${pkgver}_linux_amd64.tar.gz")
-sha256sums=('cbd16aadcb627ae98630aa680407a53e79330f228a890f11b4a7ab4faf1b65e5')
+sha256sums=('4708b1f89599f1bcd7aabd5e6a2843b2ed3580be207673b604f964b5d20cd3b5')
package() {
- gzip --force "${srcdir}"/shell2http.1
install -Dm755 "${srcdir}"/shell2http "${pkgdir}/usr/bin/shell2http"
install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 shell2http.1.gz -t "${pkgdir}/usr/share/man/man1"
+ install -Dm644 shell2http.1 -t "${pkgdir}/usr/share/man/man1"
}
# vim:set ts=2 sw=2 et: