summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukbeom Kim2016-04-09 04:10:15 +0800
committerSukbeom Kim2016-04-09 04:10:15 +0800
commit7d7eb445fd68e4fa2d2bd165508add2843fa1c26 (patch)
tree44e7caa28dfca73308afb96c423ae6527368abe5
downloadaur-7d7eb445fd68e4fa2d2bd165508add2843fa1c26.tar.gz
Initialize shell_shortcut package. Simple shortcut script for terminal environment.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52285791f54e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = shell_shortcut
+ pkgdesc = Simple script to use shortcuts in terminal environment.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/seokbeomKim/shell_shortcut
+ arch = any
+ license = GPL
+ source = git://github.com/seokbeomKim/shell_shortcut
+ md5sums = SKIP
+
+pkgname = shell_shortcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a44f8e73857e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sukbeom Kim <sukbeom.kim@gmail.com>
+pkgname=shell_shortcut
+pkgver=0.1
+pkgrel=1
+pkgdesc="Simple script to use shortcuts in terminal environment."
+arch=('any')
+url="https://github.com/seokbeomKim/shell_shortcut"
+license=('GPL')
+depends=('')
+source=("git://github.com/seokbeomKim/shell_shortcut")
+md5sums=('SKIP')
+
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ sed -e 's/\(CONFIG_FILE=\)\(.*\)/\1\/usr\/local\/etc\/config_shortcut/g' bin_shortcut
+ sed -e 's/\(PATH_FILE=\)\(.*\)/\1\/usr\/local\/etc\/path_shortcut/g' bin_shortcut
+
+ install -Dm755 bin_shortcut ${pkgdir}/usr/local/bin/bin_shortcut
+ install -Dm644 config_shortcut ${pkgdir}/usr/local/etc/config_shortcut
+ install -Dm644 path_shortcut ${pkgdir}/usr/local/etc/path_shortcut
+
+ echo "To run the script, type \'bin_shortcut -l\'. You can use it easily within alias. If you'd like to \
+ get more information, please visit https://github.com/seokbeomKim/shell_shortcut";
+}