summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-05-28 13:07:38 +1000
committerJustin Dray2015-05-28 13:07:38 +1000
commit97cdd8bde05aacfb17c863093a2b8b133bee2d34 (patch)
treef7cb9614f1e55be383a34f7861af8ddbe25ce3b3
downloadaur-97cdd8bde05aacfb17c863093a2b8b133bee2d34.tar.gz
Cleaned up organization for arch packages in prep for aur4
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cb246d93beb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = shellcheck-git
+ pkgdesc = A shell script static analysis tool: Git Release
+ pkgver = 0.3.7.r1.gbb7ef58
+ pkgrel = 1
+ url = http://www.shellcheck.net/
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ makedepends = ghc
+ makedepends = haskell-json
+ makedepends = haskell-mtl
+ makedepends = haskell-parsec
+ makedepends = haskell-quickcheck
+ makedepends = haskell-regex-tdfa
+ depends = gmp
+ provides = shellcheck
+ conflicts = shellcheck
+ source = shellcheck-git::git+https://github.com/koalaman/shellcheck.git
+ md5sums = SKIP
+
+pkgname = shellcheck-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ca03b05c468
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+shellcheck-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8ed6d8e08a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Josh McGee <josh.s.mcgee@gmail.com>
+# Contributor: Earnestly <zibeon@gmail.com>
+
+pkgname=shellcheck-git
+pkgver=0.3.7.r1.gbb7ef58
+pkgrel=1
+pkgdesc="A shell script static analysis tool: Git Release"
+arch=(i686 x86_64)
+url=http://www.shellcheck.net/
+license=('AGPL3')
+depends=('gmp')
+makedepends=('git'
+ 'ghc'
+ 'haskell-json'
+ 'haskell-mtl'
+ 'haskell-parsec'
+ 'haskell-quickcheck'
+ 'haskell-regex-tdfa')
+provides=(shellcheck)
+conflicts=(shellcheck)
+source=("$pkgname::git+https://github.com/koalaman/shellcheck.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed -r 's/^v//g;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ runhaskell Setup configure --prefix=/usr --docdir="/usr/share/doc/${pkgname}" -O
+}
+
+build() {
+ cd "$pkgname"
+ runhaskell Setup -v build
+}
+
+package() {
+ cd "$pkgname"
+ runhaskell Setup copy --destdir="${pkgdir}"
+}