summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Kitching2017-11-14 15:03:58 +0000
committerChris Kitching2017-11-14 15:03:58 +0000
commit294971da45eaf0011b7dfdc666cd429f599fd04d (patch)
treedcfb955427d643e5f79308f15d2f315ad9d509c8
downloadaur-294971da45eaf0011b7dfdc666cd429f599fd04d.tar.gz
A latest-release version of shellcheck
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96dd48647b62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Nov 14 15:03:55 UTC 2017
+pkgbase = shellcheck-git-static
+ pkgdesc = shellcheck-static, but using the latest-commit builds maintained by the author
+ pkgver = 0.4.6
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ depends = gmp
+ provides = shellcheck=0.4.6
+ conflicts = shellcheck
+ source = https://storage.googleapis.com/shellcheck/shellcheck-latest.linux.x86_64.tar.xz
+ source = git+https://github.com/koalaman/shellcheck.git#branch=master
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = shellcheck-git-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49aa03354038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=shellcheck-git-static
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="shellcheck-static, but using the latest-commit builds maintained by the author"
+license=("AGPL3")
+arch=("i686" "x86_64")
+depends=('gmp')
+conflicts=("shellcheck")
+provides=("shellcheck=0.4.6")
+
+source=(
+ "https://storage.googleapis.com/shellcheck/shellcheck-latest.linux.x86_64.tar.xz"
+
+ # We need this just to compute the pkgver to use :D
+ "git+https://github.com/koalaman/shellcheck.git#branch=master"
+)
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/shellcheck"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/shellcheck-latest"
+ install -Dt "${pkgdir}/usr/bin" "shellcheck"
+ install -Dt "${pkgdir}/usr/share/shellcheck" "LICENSE.txt" "README.txt"
+}