summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Kitching2018-05-28 17:13:03 +0100
committerChris Kitching2018-05-28 17:13:03 +0100
commitadf63bb646bcc43d8548f9e60e575fa70a97776f (patch)
tree3f3aeae59cbe7069aaca4ec6c5f97992b1cb8503
parent294971da45eaf0011b7dfdc666cd429f599fd04d (diff)
downloadaur-adf63bb646bcc43d8548f9e60e575fa70a97776f.tar.gz
Avoid fetching the git repo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96dd48647b62..6dbb2cbbfeaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
# Generated by mksrcinfo v8
-# Tue Nov 14 15:03:55 UTC 2017
+# Mon May 28 16:12:48 UTC 2018
pkgbase = shellcheck-git-static
pkgdesc = shellcheck-static, but using the latest-commit builds maintained by the author
- pkgver = 0.4.6
+ pkgver = 0.4.7
pkgrel = 1
arch = i686
arch = x86_64
license = AGPL3
depends = gmp
- provides = shellcheck=0.4.6
+ provides = shellcheck=0.4.7
conflicts = shellcheck
source = https://storage.googleapis.com/shellcheck/shellcheck-latest.linux.x86_64.tar.xz
- source = git+https://github.com/koalaman/shellcheck.git#branch=master
- sha256sums = SKIP
sha256sums = SKIP
pkgname = shellcheck-git-static
diff --git a/PKGBUILD b/PKGBUILD
index 49aa03354038..d5eb278d473d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
pkgname=shellcheck-git-static
-pkgver=0.4.6
+pkgver=0.4.7
pkgrel=1
pkgdesc="shellcheck-static, but using the latest-commit builds maintained by the author"
license=("AGPL3")
arch=("i686" "x86_64")
depends=('gmp')
conflicts=("shellcheck")
-provides=("shellcheck=0.4.6")
+provides=("shellcheck=${pkgver}")
source=(
"https://storage.googleapis.com/shellcheck/shellcheck-latest.linux.x86_64.tar.xz"
-
- # We need this just to compute the pkgver to use :D
- "git+https://github.com/koalaman/shellcheck.git#branch=master"
)
-sha256sums=('SKIP' 'SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/shellcheck"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/shellcheck-latest"
+ ./shellcheck -V | sed -nE 's/^version: (.*)$/\1/p'
}
package() {