summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchrottfresse2017-12-13 11:20:54 +0100
committerSchrottfresse2017-12-13 11:20:54 +0100
commit82193b6a6cd137374179c1cdfd850de19842d3ae (patch)
tree04f1d04e912855f1a888ccd0c8a684b45f52ea9e
downloadaur-82193b6a6cd137374179c1cdfd850de19842d3ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD25
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57b1b8b99fb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = shelldap
+ pkgdesc = A handy shell-like interface for browsing LDAP servers and editing their content.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://code.martini.nu/shelldap
+ arch = any
+ license = BSD
+ depends = perl
+ depends = perl-yaml-syck
+ depends = perl-digest-perl-md5
+ depends = perl-ldap
+ depends = perl-algorithm-diff
+ depends = perl-term-readkey
+ depends = perl-term-readline-gnu
+ optdepends = perl-io-socket-ssl: for use with ldaps:// servers
+ optdepends = perl-authen-sasl: SASL authentication
+ provides = shelldap
+ source = https://bitbucket.org/mahlon/shelldap/downloads/shelldap-1.4.0.tar.gz
+ source = LICENSE
+ sha256sums = 91889c277e9c7dd470abf017ac73c02ab2a95aac355de4dd7c77f0c7fadef31d
+ sha256sums = b180006176b4caf900df38b3365b09413f8783478fae8bcb8f73b6cb794a4116
+
+pkgname = shelldap
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bcdc060b6429
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+Copyright (c) 2006-2015, Mahlon E. Smith <mahlon@martini.nu>
+All rights reserved.
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ * Neither the name of Mahlon E. Smith nor the names of his
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND ANY
+EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE REGENTS AND CONTRIBUTORS BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bf92332b1d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Schrottfresse <schrottfresse@gmx.de>
+
+pkgname=shelldap
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A handy shell-like interface for browsing LDAP servers and editing their content."
+arch=('any')
+url="http://code.martini.nu/shelldap"
+license=('BSD')
+depends=('perl' 'perl-yaml-syck' 'perl-digest-perl-md5' 'perl-ldap' 'perl-algorithm-diff' 'perl-term-readkey' 'perl-term-readline-gnu')
+makedepends=()
+optdepends=('perl-io-socket-ssl: for use with ldaps:// servers'
+ 'perl-authen-sasl: SASL authentication')
+provides=('shelldap')
+source=("https://bitbucket.org/mahlon/shelldap/downloads/${pkgname}-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('91889c277e9c7dd470abf017ac73c02ab2a95aac355de4dd7c77f0c7fadef31d'
+ 'b180006176b4caf900df38b3365b09413f8783478fae8bcb8f73b6cb794a4116')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -m 644 -Dt "$pkgdir/usr/share/doc/shelldap/" USAGE README.md CHANGELOG CONTRIBUTORS
+ install -m 644 -Dt "$pkgdir/usr/share/licenses/$pkgname/" ../LICENSE
+ install -Dt "$pkgdir/usr/bin/" shelldap
+}